Tidal streaming stopped working for me on some devices

Core Machine
MacOS 11.2.2, Mac Mini 2014, 3GHz Dual Core i7, 16GB RAM.

Network Details
Asus RT-AC68U router over wired ethernet to Core and Audio Devices.

Audio Devices

Mytek Brooklyn Bridge
Meridian 218

Library Size
Approx 1,000 local tracks

Description of Issue

Tidal streaming no longer works for me via Roon for some devices. When I attempt to play any Tidal track on failing devices, I get the error “Unexpected error communicating with audio device” and Roon skips until it finds the next local or Qobuz (non-Tidal) track to play. If it’s a Tidal-only playlist, after failing on a few tracks, the error, “Too many failures. Stopping playback” appears and nothing plays. I have tried logging out/into Tidal again and restarting my Core. I also tried playing the same Tidal tracks on the Core (Mac Mini) via System audio and they do play via the MM’s internal speaker. Tidal does work on my Meridian 218 via Soolos, but not my Mytek Brooklyn Bridge, or my MacBook Pro when that’s set as an audio device. Qobuz/local files work fine on all devices. Can anyone help please?

After some more time looking at this, I have worked out the following -

  1. It’s only happening on Tidal MQA tracks - and not on Tidal non-MQA flacs.
  2. If I turn off my DSP settings, the MQAs play fine.
    So, I’m thinking it must be to do with preserving the MQA tag or something?
    I can also verify the above by turning on the DSP mid MQA track and it fails, skips and moves on to the next track.
    This (DSP causing the failures) makes sense with my initial post, as I didn’t have DSP filters applied on those other audio devices that worked.
    Please can @support advise if you can use DSP with MQA? Or how I can work around this (if possible)?

Hey @Jonathan_Silver,

Thanks for following up on your post and for sharing in such clear detail the behavior you’re experiencing. To answer your final question:

can use DSP with MQA? Or how I can work around this (if possible)?

I’ve looped in our technical team so they can share the most accurate answer.

1 Like

Tidal Authentication looks to have changed on certain devices. I have a DAP that was affected.

Hi @beka , I didn’t hear anything back from the technical team. Please could you ask them to get in touch?

Hi there @beka - please could you chase this up? Or is there some other way I should make contact?

Hey @Jonathan_Silver,

Thanks for following up on this :pray:

I’m so sorry there was no reply yet. I have circled back with our technicians. It won’t be much longer :mantelpiece_clock:

Hi @Jonathan_Silver

Can you reproduce this issue for me and note the time that the error occurs and what the track name is? After that, please use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service) and we’ll take a look at what happened during that time.

Hi @dylan - thanks - I reproduced the issue today at 17:56 (UK time) trying to listen to Sunburn by Muse on Tidal, with DSP on. You can find my log files here: Dropbox - jonathan_silver.zip - Simplify your life

Hi @dylan - any thoughts? thanks

@dylan @support @beka would somebody please respond?

Hey @Jonathan_Silver, sorry it’s taken so long for us to get to ya. :disappointed: This sounds an awful lot like a known bug when using Procedural EQ Mix on MQA tracks.

You mentioned the issue doesn’t persist when you turn DSP off – do you have Procedural EQ Mix enabled? If you turn just Procedural EQ Mix off, does the issue persist? If so, let’s get a screenshot of your Signal Path and take it from there.

@kevin have you even read what I wrote above? It’s over two weeks later and you’re asking questions I’ve already given clear answers to. Thinking about cancelling my Roon subscription at this point.

I did indeed, but I don’t see where you mentioned having Procedural EQ Mix enabled? It’s possible to use DSP with MQA, but there is a bug with this particular setting.

If you have Procedural EQ Mix enabled, then it’s a known bug that we’re investigating further. If you don’t have this setting enabled, then we know we need to look elsewhere.

Hi @kevin it is the procedural EQ within DSP. I’m annoyed because whilst I have Qobuz and use it as my main service, I had a free trial with Tidal and this expired on June 6th without having resolved the problem I raised on May 21st. Getting support from Roon really isn’t easy.

Hi @kevin - please can you respond?

Hi @kevin - please can you respond?

@Jonathan_Silver Better to use the general address to get customer support. Good luck.

Flagged @support for you.

1 Like

Hey @Jonathan_Silver, sorry for the delay, and thanks for clarifying that you do have Procedural EQ Mix enabled. As I mentioned earlier, what you’re experiencing is a known bug – there’s a ticket in for our developers to look at this further, but I don’t have a timeline for a resolution that I can share today.

In the meantime, don’t hesitate to let me know if there’s anything else I can help with, and I’ll be sure to update you when there’s more to share on this.