TIDAL - "Too Many Failures" Message

When I search Tidal it comes up with tracks *(that are not in my library) but I get the same message: ‘Too many Failures’.

I have undertaken all of the earlier suggestions.

I am on a Mac Mini.

My Firewall is off.


Hello @Bill_Gardyne,

Thanks for contacting support, I’d be happy to take a look over this issue with you. I have split your post from the previous thread so that we can better track this issue. You mentioned that you have already tried to “disable” and then “re-enable” your TIDAL account.

I have a few questions to properly begin troubleshooting here:

  • Can you please let me know if this issue is affecting all of your endpoints or only one of the endpoints?
  • Does local content play ok or does this issue affect locally saved files as well?
  • How is your Core connected to the internet in this case, through Ethernet or WiFi?
  • If the Core is connected via WiFi, is there any change when connecting it through Ethernet?
  • Have you tried rebooting the Core and any relevant networking gear (Router/Switches, ect).
  • Are you using any Powerline extensions?

Please let me know your reply to the above questions when possible.


Hi Norris

Core is MacMini 2011 2.5GHz, 8GB RAM, System 10.13.6
Library is on Ethernet connected Synology NAS
Roon 1.5 (Build 354)
Wireless from router to MacMini
(Speedtest 56/5 Mbps)
PS Audio PerfectWave Dac Mk II via USB

I previously had a Roon account on this set-up with no Tidal issues over 1 year. Same set-up, now different location with new lifetime subscription.

Tidal listings show on searches are extensive, but none will play, including items previously added to Library. All show that ‘This track is not currently available from Tidal. Transport: Too many failures.’

• I only have one endpoint (PS Audio DAC via USB)
• Local files OK, but Tidal items marked as’ Add to Library’ do not play
• WiFi connection - Have turned both router and Wireless connection on and off several times with 1 minute wait before reconnecting power, ( Internet connection is fast. See above) Cannot find ethernet cable at present. Advise if this is a needed step given that network speed is not an issue.
• Have deleted Roon cache in Library, and rebooted both Core and Roon.
• Powerline extensions??? Not sure what you mean.

  • All power goes through a PS Audio Power Plant Premier with equipment on separate zones.
  • USB Regen between MacMini and DAC. This is powered by an external 12v linear power supply.


Hi Bill,
Did you change location to a different country ? I think TIDAL can have different versions for different countries.

Hi Andy,

No my country is the same.

I checked and there is no where in Roon’s settings where one can nominate a country.

My previous annual subscription worked without a problem.

My new Lifetime Subscription has not worked at all with Tidal’s library.


Just to clarify, Roon doesn’t bother about your location; it’s TIDAL streaming that is geographically checked (by the TIDAL service directly). Music licensing is done on a country-by-country basis, so albums that may be available in one country are not necessarily available in another. That’s what lay behind Andy’s question. Since you’re in the same country, that’s not the cause of your issue.

The powerline question from Noris refers to the technology of running ethernet over powerlines. Some of the products available to do this are notorious for causing network issues.


Hello @Bill_Gardyne,

Thanks for providing the above information. Can I please ask you to check the DNS settings on your Router? In cases similar to yours, changing the Router’s DNS information to Google’s DNS ( has helped resolve issues for previous users. This may be the case here for you as well and is worth a look.

Also, would you be able to manually send us the logs from your machine or let me know if you have another email associated with your Roon account via Private Message? I would like to enable diagnostics mode for your account as to verify if Roon is outputting any errors but it seems that your Community account does not have any Core machine associated with it. Please let me know this information via PM or manually send the logs when possible.


Hello @Bill_Gardyne,

Thank you for sending us those log files. I can see that you are experiencing some Name Resolution Failures in the logs and I would recommend changing your DNS in the Router settings to Google’s DNS ( and possibly also in the OSX itself.

You can use these instructions to change your DNS on the Mac Mini: http://osxdaily.com/2015/12/05/change-dns-server-settings-mac-os-x/ and for changing it in the Router you would have to refer to the manufacturer’s guide.

Please let me know if my above suggestion helps resolve the issue.


my roon has the same problem since yesterday. Two error messages appear:
“This title is not available on Tidal” AND “Too many errors. Playback stopped.”
I can hear Tidal on my Sonos System AND I can play my library with Roon.

I started my mac and roon new and everything is ok.
Is this normal?
I want to buy me a nuc system with roon rock - would it be the same?

Hello @Juergen_Kijek,

Glad to hear that everything is working now!
Yes, you can install ROCK using these instructions on the NUC. ROCK operated in the same way that the regular Roon app does but since it is a dedicated machine and a linux-based OS with no extra bloatware, it often times works even better than a multipurpose setup. I hope this helps!