TIDAL tracks do not play

Core Machine (Operating system/System info/Roon build number)

QNAP Roon version 1.7 (build 667)
Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired network,
Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Roon Bridge on Raspberry Pi with Justboom board, wired ethernet connection. Roon version 1.7 (build 667)
Description Of Issue

TIDAL tracks do not play, the track appears to load but the counter stays at 0:00 and it does not play.
Local files play without a problem.
I can log onto TIDAL on my computer and play tracks from there.
I have logged out of TIDAL and back in again in Roon.
I have restarted Roon core and I have restarted the machine it is running on.
I have restarted my router.

Hi @Bart_Maguire,

Can you give some additional details about your network? What is the router you’re using? Any switches or other gear? How is the QNAP Core connected?

As a test, can you go to Settings > Services, choose TIDAL, and set the streaming quality to the lowest option? Do things work okay when doing so?

The router is a Technicolor MediaAccess TG589vac v2.
There is a HP 1820-48G switch.
The QNAP is connected with a wired connection to the switch.
I have set the TIDAL to the lowest streaming quality but it still does not play.

I’m having the same problem. Sometimes it starts playing Tidal tracks but stops soon after stating that Tidal tracks are loading too slowly and suggests checking network.
Tidal app plays fine.

I have high speed internet connection and it all used to work fine until a few days ago.

Having the same issue - tracks are skipping like crazy saying they are not available on Tidal though my internet is fine.

These all sound like networking issues. Whilst awaiting for Dylan’s return, I would suggest rebooting your routers and reviewing this for some ideas that typically help in these situations:

Still not working here.
I have restarted everything, all the remotes, the Core, the QNAP machine the Core is hosted on, the router, the switch.
I have logged out of TIDAL in Roon and logged back in.
I have restored a backup from last week, when Roon was last working.
I have stopped and removed the Core and re-installed it.
I can play everything in Roon that is hosted locally, I cannot play anything on TIDAL, either from my library or from the TIDAL page in Roon.
I can log onto TIDAL on my phone or computer and I can see the albums I have added via Roon and I can play them with the TIDAL app.
Nothing has changed on my network since last week but I have restarted everything nonetheless.
Can you fix this problem? Are there any logs I can send you which will help?

I suspect you have this problem only with aac files on tidal.

There’s an ongoing issue with aac files played from qnap core

See here

That looks like the problem.
I have a few local aac files, so I have just tried to play them and I get the same result - they do not play.
I also have some radio stations which do not play the aac stream but will play the mp3 stream.

For other QNAP users - I have fixed this (temporarily) by updating ffmpeg on the QNAP.
Go to the AppCenter/QnapClub and install ffmpeg 4.3.0 from there. Follow the directions to link it into the path and restart Roon core.
I imagine this will not survive a reboot or a firmware update and it might break other things in QNAP so be prepared to re-link to the supplied ffmpeg.
Could Roon and/or QNAP fix this officially for us?


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.