Tidal tracks glitch in first few seconds

Core Machine (Operating system/System info/Roon build number)

Ubuntu Linux 18.04.4 LTS (running in a VM), 4GB RAM, 8 cores
Roon 1.7 build 511

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

WiFi on Apple Airport Extreme, connected to an HP ProCurve 3400cl switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

I’ve tried HiFiBerry DAC+ (wifi), HiFiBerry Digi+ (wired), bith running Ropiee on a Rpi2B+; and MacOS CoreAudio (wifi) on a late 2013 MacBook Pro.

Description Of Issue

Any flac track from Tidal plays for about 3 seconds, then restarts again from the beginning as a “glitch”. MQA tracks seem to glitch at the first second. This is not reflected in the track time counter, which keeps going up as if nothing was wrong. It started a couple of days ago, and I can find nothing abnormal in either the roon core logs or bridge logs on any device. Tracks that I’ve ripped from CD play fine.

I’ve tried rebooting the core and bridges, and deleting the Cache directory on the core, but there’s no change.

Hi @Kiril_Dunn,

Does the same behavior occur if you play to a different endpoint like System Output of a remote?

Are you using any DSP settings?

Thanks for the quick response. The Digi+ has a headroom adjustment, but otherwise no DSP settings anywhere. I just tried from my iPhone with a private zone and all default settings, and the same issue occurs on a track I have never played before on any device.

Some more info: this occurs for Tidal only – I just signed up for a Qobuz trial and it works fine. Logging out of Tidal in Roon and logging back in didn’t help.

Thanks for the details, @Kiril_Dunn.

As a test, I was hoping you could try using the Mac as your Core machine temporarily. You can do this by going to Settings > General and choosing Disconnect. Then, you can choose This Mac as your Core. From here, login to TIDAL and try playing to System Output — Does the same behavior occur?

A post was split to a new topic: TIDAL playback glitch on older Airport device

@dylan Just tried it: no difference. I’ll try with a wired connection this evening and see if that changes anything, just to eliminate the Airport Extreme as a problem (@Armando_Maynez I’m not using it as an endpoint, just an access point).


Hi @Kiril_Dunn,

Thanks for the update! Definitely let us know if a wired connection helps here.

Just tried with wired - it still glitches in the first few seconds.

@dylan Any suggestions? If not, I guess I’ll be cancelling Tidal and sticking with Qobuz.

Hi @Kiril_Dunn,

Can you reproduce this once more and do the following:

  • Record a video of this happening if possible
  • Note the track that this occurred on
  • Note the time that this glitch occurs in your local timezone

Respond here with the track, timestamp, and video and we’ll enable diagnostics so we can take a closer look.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.