TIDAL tracks not playing [resolved: 790 improved]

Hi @danny ,

VPN is not used in my setup. I understand your reasoning that it is a network setup related, but the same setup was used since September last year, yet the issue only started recently since I upgraded to Roon 1.8.

… but if you are streaming the same quality content from the same machine/setup, I’d be surprised if you didn’t have the same situation there.

I have a dedicated NUC (ubuntu) with Roon core on it. I cannot stream Tidal from it outside of the Roon, it only has the Roon core on it. However, I used Audirvana for streaming from the same network (using my Mac) and I never had this kind of issues. I have other Tidal enabled clients in the same network and they never had this issue, they all happilly play HiRes content from Tidal.

1 Like

Then why can I play the exact same songs directly on Tidal when it happens on Tidal through Roon?

1 Like

And I didn’t have skipping issues playing Tidal through Sonos. I borrowed my girlfriend Sonos Port and set it up on a separate input to my audio system in the same room, same router and it never skipped in 2 weeks.

1 Like

Hello @danny,
from my point of view - sorry, for my direct speech - your answer and maybe the thinking behind it is exactly part of the problem! And maybe I’m wrong, but all the feedbacks we get here are…

In summary: issues with our network, our equipment, our whatever…

And I agree with you - I guess you are experiencing a lot which is not roons fault. Point taken.

But all the other Apps (because of this skipping title issue) do NOT have a problem and only your roon software causing trouble (my exierience and from many others too).
I really like your software, I’m a fan of it, I’ll try to be helpful, I like all the features and the idea of roon but I really have a problem with your roon support and that way of thinking.
I counted 42 people which are having an issue with that title skipping within 15days.
I’ll go through a whole month of threads and will provide the monthly figure. The first 42 names I have already noted.
I really think it is worth it to fight for a good solution and your programm is good (if it works).
All I want it is some commitment from roon for these issues. I don’t want to have it fixed in days, if there is a future. All I read so far is NO commitment, answers and feedback are by far not enough.
That’s at least my opinion.
And if it won’t help to address that here I’ll write to all German HiFi Magazines and people like Raphael Voigt which do a lot of for advertising for roon and I’ll ask them if they are aware of the situation.
Maybe letters to the editor sharpens your point of view.
Otherwise I’ll cancel this experiment - but it is NOT really my intention.
So, please help and tell your guys it’s an important issue, try to get Tidal involved because my point of view is also that there must be a reason for less issues with Qobuz (than Tidal). But roon has to be more robust. Sorry, I’m p…d, frustrated,…
Thanks.

Every time we actually dig into this, it’s always a misconfigured DNS, or bad router, or funny VPN/VLAN/setup issue. Always. It’s never once been an actionable change on our end.

For example, one recent user’s issue that was resolved by removing the VPN, was exactly as you describe. He has no problems before, he had zero configuration changes on his end, all he did was upgrade to Roon 1.8, and the TIDAL app works just fine for him, whereas Roon has networking issues.

Turns out he forgot he added a VPN and when he said the TIDAL app works, it was on a different device (mobile), and was that device was configured to stream lower quality streams.

Another person was sure it was 1.8 as well, but it turns out he was fiddling with DNS settings around the same time, and when he put back his DNS settings to default, all worked out. Again, it worked on his phone, because he was streaming over the cellular network using the ISP’s DNS, and not his local router.

This story repeats itself over and over. I wish I could fix something here, but I have no actionable information to do so.

Let’s try something:

Do any of you have a situation where you have a computer that is running a Roon Core and also the exact same computer is running TIDAL, and when you use either Roon or TIDAL to play to the exact same endpoint (via USB or built-in audio), Roon fails but TIDAL succeeds? If so, I’d be interested in seeing TIDAL app configuration screenshots and Roon signal path screenshots – I’d also like to see Roon Core logs from that failure.

You need to be playing the exact same content, and I want to make sure you have no networking funny business, which would include any firewalls, VPNs, VLANs, virtual machines, emulators, etc… Even apps like Little Snitch could be interfering (we had a user that once was throttling Roon traffic accidentally), so I want them out of the equation.

See above, too many variables. For all I know, your port was not streaming FLAC. Let’s get to the bottom of this by creating an apples to apples comparison.

Run your Roon Core on the same Mac and play the same music to the same outputs. Does it work?

The code for handing TIDAL and Qobuz streaming is identical. The only difference is how the stream is authenticated. The fact that more complain about TIDAL tells me that either this is a problem on TIDAL’s end, or than more people use TIDAL.

You also have to understand the extreme frustration when I pay my employees or take my own time to resolve these issues, only to find out that a user has been fiddling with settings they don’t understand or has left out an important detail about their setup, and that detail is the one causing the error. Or, when the problem is about a setting in a router, modem, or some additional gear / setup / configuration they’ve chosen.

Example:

I can go on and on…

but yah, read my post above and try to give me actionable information – do an apples to apples comparison, and give me screenshots and logs to help diagnose the issue.

Thank you @danny I really appreciate your feedback.
And I understand your point of view. But please understand also our issues as well!

As I stated I will really support and hope we’ll come to an positive output.

One point of course is that I cannot deliver a Tidal connect and roon results at the exact same time.
What I figured out is that Tidal server issues are sometimes happens for a longer period.
At least what I found out on German Tidal server outages webpages.
So when I discover issues with roon I’ll switch over to Tidal connect, I can always use the Roon Core PC also as an output for both Apps because a very nice highend stereo system is connected to the PC. I also have a friend which only uses Tidal connect to play music and never got these nice issues.

I’ll promise I’ll deliver everything.
What do you mean by Tidal connect App configuration - Could you please give me an hint what do you want to see - you’ll get it. Is it okay if the screenshots will be in German - shall I try to translate?
What do you mean by roon signal path screenshot?
Thanks for your attention.

Oh I see I’ve to follow up…

I agree, my thoughts as well. But why don’t you get in touch with Tidal, I thought you have a strong relationship. Or tell me how I can kick their ass. What I did so far is that I created a ticket Tidal outages and always if I experience outages from Tidal I create reports on an Downtime web page.
Trust me I’m not just in contact with roon.

I agree and I do understand.
If I made something completely wrong and I’ll or you’ll find out I’ll deliver a package of beer to you - hopefully this will be possible by internet. You can bet on it - even if I know beer is much more expensive in UK or US than in Bavaria.

[quote=“Titles Skipping constantly [resolved - deselected the Package Accelerator in Fritz Box], post:28, topic:150826”]
Guys, I did deselect the Package Accelerator in the Fritz Box and can confirm:
[/quote]

I doubt that and as you may have read I was personally in contact with AVM Fritzbox.
Fritzbox options only work for that session and will be reseted at the next router start.
Maybe a good day from Tidal server made that conclusion or AVM told me the wrong information.

I’ll try to do so and if I cannot deliver something I’ll get in touch with you.
Thanks for your support from a big music fan. :wink:

@danny

I installed the Tidal app on my MacMini core… but I can’t play both Tidal and Roon on the Macmini at the same time because Tidal will stop as soon as I start Roon (“Playback has been paused because you are playing to Roon”) What I can do is:
(1) launch a Tidal playlist from within Roon on my Macmini core (modem/router > eternet > Macmini system output)
(2) launch the exact same Tidal playlist using Tidal Connect on my smartphone (modem/router > wifi > Bluesound Node 2)
Would that be close enough to a ceteris paribus situation to be helpful?

No. Absolutely not.

You must use the TIDAL app on your Mac Mini and not use TIDAL Connect.

In your example, the Roon Core is subject to all the stuff installed on your Mac, but the TIDAL Connect gets to skip anything you’ve got on the Mac.

My suspicion is that your Mac is the one with the problem. One half of your test skips the Mac!

you don’t need to do it at the same time. that will never work because of how tidal sets it’s rules on the server side.

Hi @danny ,

So it’s one of those 3 things. And in my case I don’t use VPN and I used 2 different routers in the past with same issues in Roon. Which leaves me with the misconfigured DNS. I use 8.8.8.8 for DNS. What is the Roon recommendation for DNS server ? How can I check if my DNS is misconfigured?

Thanks
E

routers are just a small part of the network.

are you able to play in the TIDAL app on the same machine to the same outputs?

8.8.8.8 or 1.1.1.1 are both good dns servers, assuming your ISP is not doing evil.

Also, I’d like to point out that while your symptoms are similar (as is the error in the log) to @Francois_De_Heel 's case, it may or may not be the same issue. I’d like to focus on individuals as unique cases, and stop tying them together. It’s confusing for us. Please try to resist the urge to do this.

In your log, it shows that the TIDAL stream is failing to load… doing TIDAL app test is a good start, especially since you already playing to the output on your Mac. You already have success using Audirvana on that Mac, it’s a good test.

1 Like

@danny

Test: Roon versus Tidal app: playing the exact same Tidal tracks on the exact same devices & network

  • Modem/router > ethernet > Macmini Roon core > system output
  • Modem/router > ethernet > Tidal app on Macmini > system output

Both in Roon & Tidal streaming quality is set to Master.

Summary of the results:
(1) Playing through Roon: 79 tracks, 8 skips
(2) Playing from Tidal: the same 79 tracks: 0 skips

Details:

I launched a Tidal playlist in Roon. From the 22 tracks that were played on May 6 from ca. 7:00 am until 8:33 am local time, there were 4 tracks that skipped midway to the next.

The first track played of the 22: “A Beautiful Woman” by Angel Deradoorian

1st skip: next song: “Soothing” by Laura Marling (played 55%)
2nd skip: two songs further: “Bedtime” by Annie Eve (played 60%)
3rd skip: five songs further: “Blue Song” by Mint Royale (played 55%)
4th skip: thirteen songs further: “Dreary Town” by Nadine Shaw (played 75%)

The last track played of the 22: “Slow Decline” by Elsiane

On May 6 at 9:44 am local time, I launched the same playlist beginning with the same “A Beautiful Woman” in the Tidal app on the same Macmini. I diligently listened for skips. There were none.

After “Slow Decline” I continued listening through Tidal for another 25 tracks. The next track after “Slow Decline” was “Friend Crush” by Friends. I diligently listened for skips. There were none.

On May 6 at 13:17 I stopped Tidal playback after “Mosquito” by Yeah Yeah Yeah and immediately returned to Roon. I played the same 25 Tidal tracks, beginning with “Friend Crush”. This time, in Roon, of the 25 tracks played, 0 skipped midway.

I let Roon continue playing. At 15:35 I started a new playlist in Roon (first track: “Anemone” by The Brian Jonestown Massacre). 3 tracks later:

5th skip: “Are You Ready” by Pacific Gas & Electric (played 20%) (around 15:42)
6th skip: eleven songs further: “Time is Tight” by Booker T. & the MG’s (played 75%)
7th skip: two songs later: “For Your Love” by The Yardbirds (played 45%)
8th skip: five songs later: “Somebody Stole My Thunder” by Georgie Fame (played 70%)

I stopped Roon playback at 17:23 (last track played: “Melting Pot” by Booker T. & the MG’s)

I restarted the Tidal app and played the same 32 tracks starting from “Anemone” by Brian Jonestown Massacre and ending with “Melting Pot” by Booker T. & the MG’s. I diligently listened for skips. There were none.

I made a zip file of the Tidal logs. If you want them, let me know.

Some screenshots

Screenshot of Tidal playing (made with my phone, I have no apps installed on my Macmini, except Roon and – temporarily - Tidal).



2 Likes

I have an idea… it may be easy to test. This is just an idea, and I’m just guessing here. Remember, 99+% of the TIDAL streams in Roon do not have issues with the connection. I’m guessing as to what impacts a handful of users.

Here is my idea:

Roon downloads the TIDAL track into memory for playback when you start playing the track. TIDAL on the other hand will stream with just a tiny buffer because it makes sense to minimize their outbound bandwidth costs for people who hit next or stop in the middle of a track. No point in paying for bandwidth to stream a song you don’t play. This is a side effect of outbound traffic having a cost to them.

Early on, we found that downloading the track in its entirety helps those who have poor or intermittent internet connectivity. The results of doing this were clear, as we saw reliability go up and many users reported the opposite of what you are experiencing: they had unreliable TIDAL app streaming but solid TIDAL streaming in Roon. We all rejoiced!

I’m wondering if this download of the track is causing your ISP or router to behave badly. The test would be to see if you can reliability download large files from TIDAL. It’s hard to do this from TIDAL without writing a custom program, but we can try downloading large files from elsewhere on the internet, and if that fails, we will know that this could be the issue. The answer would be to provide a way for you to turn off this behavior.

When you are having these issues in Roon, using the same machine, using the stock OS web browser (Safari or Edge), can you attempt to download this 2.8gb file:

https://ftp.halifax.rwth-aachen.de/ubuntu-releases/21.04/ubuntu-21.04-desktop-amd64.iso

It’s an Ubuntu operating system image, and you can delete it after the fact, but I’m curious if you manage to download a full 2,818,738,176 bytes without issues.

I know it’s a bit annoying of a test, but it’ll help give us data.

1 Like

A post was merged into an existing topic: Trouble with TIDAL playback [resolved - VPN was interfering]

I just downloaded the file on the Macmini using Safari. It worked. In fact, I downloaded it, deleted it, then downloaded it again to time it. The second time it took 2 minutes and 9 seconds. I think the first time was faster.
Does this help? Does it learn us anything that is actionable?

This can’t be our downloading… look at this:

That’s a 2.8gb in 2:09! more than fast enough for audio.

Your “Dreary Town” track is 4:32, and 75% in you had been playing for 3:24. In that 3:24, you should have been able to download over 3gb, and I don’t care what format that track is in, it’s not over 3gb.

This means your system shouldn’t have been anywhere near downloading anything when this skip happened.

Weird.

I did notice something else in your logs:

05/06 07:02:42 Trace: [System Output] [zoneplayer/raat] sync System Output: realtime=27966106510758 rtt=0us offset=-5024298489us delta=-23053us drift=-3634153us in 339.7385s (-10696.915ppm, -38508.895ms/hr)

38.5 seconds over an hour of clock drift! That’s a really bad clock.

We are digging deeper… there is something going on here.

I could use some help with another test.

  1. Play in Roon and wait until you get a skip.
  2. When you skip, shut down your Roon Core. Like, kill the app/server completely.
  3. Restart the Roon Core.
  4. Play the exact same track that just skipped.

Does it work? If it doesn’t, does it skip at the same point in the track?

Haha. I’ll kill my Macmini as soon as I notice a skip. I’ll keep you posted.

You don’t need to reboot the system, just restart the Roon Core. There is a cache that will be lost in the restart, and that’s the effect I’m trying to get.

Okay, will do. Have a nice weekend!