Tidal tracks not playing since 3 days

Core Machine (Operating system/System info/Roon build number)

NUC with Roon rock 1.7, operational since about 3 years

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet connection to gl-ar750 router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB connection to adi2 dac

Description Of Issue

Since Friday no Tidal song plays anymore, all are skipped, controlled from iPad, iPhone, sent to multiple outputs… all the same… locally stored music plays fine. Tidal searching and adding music works fine… nothing changed over the last weeks, played fine day before…

Have you tried rebooting everything?

Yes, already multiple times, including the router…

Hello @Frank_Brichau, my apologies for the trouble here. Could you please try signing out and back into TIDAL via Roon? Are you having any issues play from the TIDAL app? Lastly, do you see any errors pop up when you observe this behavior?


Thanks for reaching out. Already several times re-logged into tidal. Tidal alone plays fine. In Roon tidal tracks skip to next… non-tidal tracks play normally… thanks for help…

Hello @Frank_Brichau, when you tested other outputs, did you try system output of one of your remotes?

Yes, tried it all, nothing changes… songs keep skipping, none plays…

Is this your router?

This is router, works fine since more than a year, nothing changed recently…

Hello @Frank_Brichau, and thanks for the clarification. Could you please try changing DNS and see if that helps? Or connect your core temporarily to a mobile hotspot or a separate network and playing to system output to see if the issue occurs there too?

Hi nuwriy,

Still same issue… what do you mean with dns?




Still not solved. Used other router, same issue. in roon settings/services wheel in front of login button keeps turning. normal?



Hello @Frank_Brichau, my apologies for not getting back to you sooner. You can learn about changing DNS here.

Where to change in rock operating system, being Linux or on rock web page system? Why change now? It worked for years…

Changed dns in router… no change…please help this lasts already for weeks…

Hello @Frank_Brichau, could you please change your default browser and try logging in again?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.