Tidal tracks skip

Roon Core Machine

Grimm MU1

Networking Gear & Setup Details

ASUS AX88U wired, with Etherregen switches

Connected Audio Devices

Ayre QX-5 Twenty

Number of Tracks in Library


Description of Issue

Tidal tracks stopping and skipping. The message is: Tidal media is loading slowly. No problems at all with Qobuz or locally stored tracks. I tried restarting the core and switches and a logout from and login to Tidal, to no avail.

Any ideas? Thanks.

The Roon/Tidal skipping problem is usually related to some sort of networking issue - even fast internet connections can have underlying issues, such as with the DNS servers your ISP uses. You have restarted your core and switches, but I’d suggest the following:

I assume the Grimm is connected via ethernet?
Logout from Tidal on all devices, login again from Roon
Set your router to use Cloudflare DNS servers - and
Reboot modem, router, switches
Reboot Roon core and the Ayre
If none of that makes a difference, then maybe try connecting the core directly to the router without the switch in the chain, and try another ethernet cable


Thanks @Rockhound.

The only thing I hadn’t tried before was rebooting the modem. That did the trick. Solved!


1 Like

Glad you got it working - enjoy the music!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.