Tidal - won’t recognize password

I have been using Roon for months now and it is wonderful. However, yesterday it stopped recognizing my tidal subscription. I thought it may have something to do with the password, so I reset it. I have now reset my Tidal password four times and still get the same error message listed above. I currently run Roon from my iphone, with the output to core Innuos Zenith SE with Kii Three speakers.

Hey @Robert_Gries — Thanks for reaching out!

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Since this behavior has started occurring have you tried rebooting your Core machine?


1 Like

Had the same problem today. Closed and reopened Roon and all is well.

Turned off and on the Innuous Zenith SE, then reinstalled the Roon app on my iPhone and now it works! Thank you so much.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.