Tidal won't login after latest roon update [fixed in 1.3]

After the recent Roon app update on my iPad, I also received an email on update in Tidal terms. I was kicked out of Tidal in the Roon app and cannot log back in even though I have no problem logging into the Tidal app on the IPad. Have logged a support request to Tidal but I’m not sure if this is a Roon app issue or a Tidal issue.

Using Roon through Antipodes DX.k

Have tried restarting roon server with no improvements in Tidal working.

Just an update on my specs, I have a QNAP 251+ nas 4TB raid 1 running roon server build 165 that streams my music to a DAC, all flac/dsd and nas library works since the update on Nov 21 have had no issues except for the tidal login problem. No issues with Tidal’s own apps working in my network.

My controllers are 2 android associated roon remotes and a MacOSx Yosemite iMac, all 3 have roon remote tidal login issues.

I too had the same issues after agreeing to an update in Tidal terms, coincidence or something on Tidal’s end?

Roon team, hope you guys have a solution!


My system has recently developed problems connecting to Tidal and retrieving Roon account information, don’t know if the two problems are related. Can still login to both Tidal and Roon accounts from Chrome and/or IOS. Tried reentering Tidal account info within Roon but generates an error. Some days can connect to Tidal from Roon, other days no.

Roon core 1.2 build 165, 64 bit running on sonictransport

Hi @Eric_Walberg ---- Thank you for the report and my apologies for the troubles. I combined your most recent post with this thread as to keep this issue isolated in a single location. Can you confirm if you have tried:

A) Rebooting your sonictransporter?


B) Clearing your TIDAL cache?


I have rebooted multiple times, sometimes clears the Tidal linkage problem, other times no. Does anyone know to clear the Tidal cache on the Sonictransporter? @agillis

You can expose your Roon Database as a file share. Then you can delete what you need to

I have tried several reboots as well. Still can’t login to TIDAL, and when I try to delete the cache folder I am told I don’t have those permissions. Please advise. @agillis

I am running the Core on Linux.

Hi folks, the below procedure seemed to work for me.

I re-installed roon server on my Qnap 251+ in my NAS OS to Roon Server ver 1.0.1, re-installed the Roon remote build 165 on my android phone, re-mapped my music directories and that seemed to solve the tidal issues for those running it on a nap NAS.

Good luck.


You should have permissions. Did you stop Roon Server?

Sorry, Andrew. I meant to ding Roon staff, not you.

But thanks. And yes, I did quit RoonServer.

Hi @fritzg,
Let’s flag @support to check it out.

All ----- Please be advised that we believe that we have identified the cause of this problem and a fix has been set into place for 1.3. We greatly appreciate your patience.



thats great news!

I have the same issue 07/12. As 1.3 is likely days/weeks away can this not be solved sooner? This is core functionality

Playback stopped …

No issue whatsoever using Tidal app on Mac and iPhone. So nothing wrong with my account details.

Core is a NUC running Ubuntu 16.10

If you are encountering this error on a linux-based core (includes Synology, Qnap, Sonic Transporter) then the following workaround may get you going.

You need to re-start RoonServer twice in succession. Don’t reboot your core, just stop the Roon package and restart it (Synology, Qnap, Sonic Transporter). Wait until your remote reconnects and then stop and start again.

If you’re running a native linux install then stop and start Roon using systemctl.

Best to count to 10 between the stop and start just to give all of the processes a chance to exit cleanly.

And if you didn’t catch it above then I’ll reiterate. You need to stop and start Roon TWICE. No need to mess with the Tidal login or your cache directory.

Give it a shot… I’ll bet it works :slight_smile:


The technical explanation for this is that after one restart the gremlins start to regroup and rally and that’s just when the second restart takes them by surprise …


OMG the two restarts in a row worked! STi5 core. Thank you. I had tried everything else including all the cache deletes etc.

I am having this issue now as well. Unable to login to tidal with the ‘unexpected error’ message despite deleting the cache folder and restarting multiple times. I am able to login to my Tidal account fine from a browser or smartphone app. Core running in an Ubuntu based docker container hosted in unRAID 6. Core, app all updated to latest versions.

Wow. Andrew P’s suggestion of two consecutive restarts (without trying to login to Tidal in between) did the trick!