TIDAL Your Favorites page not loading [Resolved in B555]

Hi everyone,

Our team is currently investigating this issue and we are working to resolve it as soon as possible. I’ll be sure to keep everyone updated as we have more information here. Please accept our apologies for the inconvenience!

In the meantime, you can find your TIDAL content by using Focus to choose TIDAL content only:

Same issue for me. On both, my PC and my mobile.

Core Machine (Operating system/System info/Roon build number)

1.7 (build 537) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

FRITZ! Box 7590 ZE Router. Ethernet.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Devialet Expert 250 Pro

Description Of Issue

Can´t access my TIDAL favourites on both, my mobile and my PC since yesterday.

Same as Reinhold had reported.

My Tidal favorites are all gone. Happened two days ago. Sad to a new user.

I have the same problem as well, everything was working fine till I updated Roon to the latest build.

I opened ticket without realizing this was already here, this was my post below. I am happy to hear its not just me because I know its not my network or computer now.


That is correct, my Favorites are just not loading everything else loads dispite getting an error that says:

“Error loading Page, check you network connection”

I have tried clearing the cash folder in local app data. I reinstalled Roon a bunch of times, I tried connecting to Tidel via a different browser and the Roon remote. I also changed my DNS servers on my local host and router. I updated the firmware on my switch and firewall, still no go.

Qobuz works fine, my playlists from Tidel show up too, everything works but I get that error and my Favorites page from Tidel will not load.

I even reinstalled Chrome and Firefox too. Tidel works fine from the app itself too.

I also tried disabling my firewall and AV software.

Not sure what the issue is here but it seems others have had the same problem in the past. However it does not seem they found solution as well."

Same issue here. Tidal favourites not loading.

Same problem here too.

Is there any solution for this issue or is there some work in progress from Roon side?

1 Like

Same just started happening to me after 2 years of trouble-free performance. It is only Tidal favourites won’t load. Tidal rising etc work fine. All favourites still there in the Tidal app.
Rebooting (Antipodes) Core, reinstalling (android) Roon, signing out of Tidal and back in haven’t made any difference.
What next?

The same here.
Awaiting for somebody from Roon to wake up and provide some info.

Same for me too.
For me it’s nit a big issue as I tend to add them to my library anyway , but I know we all have different preferences.

There have been a few issues over the last few days I am afraid

@support tidal seems to be in a world of pain for many here me included…error loading pages on screen refreshes etc…not just this thread, many others

Same problem with Tidal favorites here too.

Hello @Vule, @Richard_Perry, @Womaz, @wizardofoz, and @Hakon_Berg,

We’re aware of the issue and actively working towards a solution:


PC Win10 Roon 1.7 build 537

100 mbit/s ASUS AC87U Router, ethernet connection

T+A MP1000E ethernet connection

Roon does not load Tidal in “your favorites”. Neither albums, artists nor tracks.
Tried logging out and in. rebooted PC. Nothing helped. Worked for 1.5 years. Problem started two days ago.

Thank you, John. Your suggested work-around helps.

Core Machine (Operating system/System info/Roon build number)

SGC SonicTransporter i5 and RoonVersion 1.7

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Orbi AC3000 router andTP-Link ethernet switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonore ultraRendu and ifi Pro iDSD DAC with a USB connection

Description Of Issue

For some reason, Roon stopped loading my Tidal “favorite” albums. That page, upon selection, says “failed to load”. I checked on the Tidal app, and they’re all still there on Tidal. They’re just not loading on Roon. Ive even logged out of my Tidal account on Roon, and then logged back in. Nothing. I rescanned my hard drive through Roon, and it hasn’t changed. Any ideas?

Having the same problem…

Hi everyone,

We just released Roon 1.7 Build 555 to address this issue. We appreciate your patience as we’ve worked to resolve this! You can read more about this here:

Note that if you don’t see the update just yet it should be available very soon for you

Roon Support Team

1 Like

Fixed the issue with loading Tidal favorites for me! Very good! Thanks

1 Like