“Too many failures. Stopped playback.” errors with Qobuz

Core Machine (Operating system/System info/Roon build number)

Intel NUC 7i3BNH running ROCK. My library music stored on the NUC on a Solid State HD.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

GPON Terminal Echolife HG8245 fibre modem.

Ethernet connection to D-LINK 905L wireless router.

Ethernet connection from D-LINK 905L to raspberry pi/HiFiBerry digi+ running roon.

All Roon controllers (android) are connected wirelessly to D-LINK router. A second raspberry pi/HiFiBerry Digi+ is connected wirelessly to same router.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Raspberry pi/HiFiBerry digi+ music players as described above. These are connected via coaxial SPDIF cables to either an RME ADI2 or Meridian Director DAC.

Description Of Issue

All Qobuz album tracks fail to play through Roon with “Playback was interrupted because a track failed to load.” and eventually “Too many failures. Stopped playback.” Playback is fine from the Qobuz website. Everything played fine through Roon 1.6 (bar one album). Problem only started after upgrade to Roon 1.7.
I can access Qobuz in Roon to view albums but can’t play any tracks. None of the Qobuz albums in my library play anymore.

I can play tracks normally if I directly login to my account on qobuz.com.

I’ve tried this so far:

  1. Services: Disabling/re-enabling Qobuz
  2. Services: Logging-out/logging-in Qobuz
  3. Rebooting ROCK
  4. Clearing /cache
  5. Rebooting network routers

So far no success.

1 Like

Hi @Stevie_B,

Sorry to hear about the difficulties here.
Can I please ask you to perform this test?

  • Try selecting your Core’s HDMI Zone
  • Have no DSP active in this zone
  • Start playback of Qobuz content
  • Note the exact local time + date of when you notice the next issue (e.g. 3:28PM 11/22/19)

Even if you have nothing connected to the HDMI zone, it would provide a valuable data point if this zone is displaying errors as well.

I selected HDMI1 on the Core and tried to play a track from a Qobuz. I had exactly the same error “Playback was interrupted …”. Time was 5.06 pm 11/22/19 according to PC and tablet (but 5.05 pm according to my watch).

Hi @Stevie_B,

Thanks for letting me know that timestamp. I have gone ahead and activated diagnostics mode for your account and what this action does is automatically upload a set of logs to our servers for analysis.

I am looking through them not and I’m noticing that playback is failing due to the network. Looking over your Network description from above, and I can’t discern how the ROCK is connected, is this going into the D-Link Router or elsewhere?

Also, how are your DNS servers on the router configured? Are you using Google / Cloudflare for DNS? Changing the DNS servers might help with the issue, so it’s worth a try.

Hi Noris,

So I re-checked Qobuz last night and it was working fine!! The one album that didn’t play before the v1.7 upgrade (Life thru a lens - Robbie Williams) still doesn’t stream but it now shows that each track is ‘unavailable’. Otherwise everything looks good.

I didn’t change anything, and I’m guessing you didn’t either, which worries me. I had a problem when I first subscribed to Tidal early in 2018. It was very inconsistent. It worked fine through their app but often failed to stream through roon. It was very unreliable so I gave up on it and switched to Qobuz in March 2019. Qobuz through roon had been totally reliable until I upgraded to v1.7. Hopefully this isn’t the start of some major frustration!

BTW, the ROCK is connected via ethernet to the D-LINK router and all the players/controllers are similarly connected to this router via ethernet or wifi. It keeps it separate from the main router/fiber modem which is controlled by the ISP.

Hi @Stevie_B,

Yes, that is correct - no changes on our side yet.

I wonder if perhaps there was an update to track availability when you tried to play this album? It’s strange for us too to hear that the issues just stopped after a few days, but we’re looking into it.

Do let me know if the behavior comes back and we can take another look, thanks.

Hi Noris,

The behavior’s back sooner than I thought. I know I should have blocked automatic updates -just wasn’t expecting one so soon! Anyway, after the latest update yesterday (build 505) I can’t stream from Qobuz again! So this certainly didn’t fix my issue.

I guess I should leave it a few days to see if it recovers of its own accord like last time.

Hi @Stevie_B,

Can you please reproduce this issue, note the exact local time + date + track when you experience it, and manually send me a copy of your Roon logs by using these instructions?
The best way to get them over to me would be via a shared Dropbox/Google Drive link. Thanks!

Hi Noris,

Streaming of Qobuz tracks is working again this morning. All good things come to those who wait! Will let you know if/when it stops working again. Thanks.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

For details of equipment and error see previous closed post.

Unfortunately the same problem returned on Monday evening (2 December). I was away for a few days but on returning today (Thursday) I am still unable to play any Qobuz tracks. Error is exactly the same as before. Please advise on tests so we can sort what is happening and get it fixed or maybe I should just return to the earlier version which worked perfectly.

Many thanks.

Hi @Stevie_B, I’ve reopened that closed topic and merged. Let’s tag @support for you.

1 Like

Hi @Stevie_B,

Downgrading is not supported by Roon for the various reasons linked in that article. Let’s proceed with my request from before:

Hi Noris,

I just went to reproduce the issue so I could send you my log files and guess what, streaming from Qobuz is working again! This behavior is very reminscent of what happened with Tidal that led me to drop that service. How do we proceed to resolve an intermittent problem? Do I just wait until it fails again and then send you the logs?


Hi @Stevie_B,

It’s a case of the Schrodinger’s cat who’s also an audiophile it seems :slight_smile:

Yes, logs in this case would be helpful in trying to identify the problems, next time it occurs/if it occurs, please do send the log files over along with a timestamp and I’ll take a look.

Hi Noris,

Just failed again. Trying to steam Enya album ‘Christmas Secrets’ at 10:36 am CST on 12/8/19. Link is: https://send.firefox.com/download/d9a7517d06bf4dca/#LSq2pVAkIPL32ODTA_94Kg

Hi @Stevie_B,

Thanks for sending those logs over. I am taking a look through them and I notice quite a few networking-related errors, it appears that Roon was unable to reach Qobuz for streaming this track.

We have seen users have a better experience in the past if they change their router’s DNS servers from the ISP provided ones to Google DNS or Cloudflare DNS. Can you please give this a try and let me know if it helps?