"Too many failures" with fresh install on Windows with Razer Leviathan

Roon Core Machine

Razer Blade 15
Windows 11

Networking Gear & Setup Details

AT&T Uverse, direct connect

Connected Audio Devices

Razer Leviathan V2 Pro

Number of Tracks in Library


Description of Issue

A new installation of Roon on a laptop. I ripped a small library for testing and connected to Tidal. Anything I attempt to play gets “Too many failures. Stopping playback.”.

I am connected directly with ethernet, not using WiFi. I tried rebooting several times, rebooted the cable model, uninstalled and reinstalled. I can’t get it to do anything. Tidal and Qobuz work fine using their own apps as does networking in general so it doesn’t look like an obvious network problem.

I had Roon installed on a different machine with no problems, even running over WiFi. That core was disabled when installing the new one.

It appears to be related to the Razer Leviathan V2 Pro sound bar. At first I had the Leviathan enabled as an output in Roon. That didn’t work. Then I disabled that in Roon and enabled only “System Output”, then in Windows 11 configured the Leviathan to be the default system output device. That didn’t work either. If I configure Windows to use the built-in audio device in the laptop it works.

So there is something about the Leviathan that makes it wonky. The Leviathan works fine for everything else.


I see something similar in another post from January that was apparently resolved by disabling the Windows Defender firewall. I tried that and it didn’t work, I don’t see what the firewall would have to do with this anyway since the sound bar is connected directly to the laptop and configured as the system output device.

I’m not expecting a response on this, but another data point. If I use Bluetooth to send audio from the computer to the Leviathan, Roon works. It is just when it is connected over USB. But then you lose out on various options to control the sound bar from the PC. Again, it works with every other audio app I have, including professional recording apps. Just not Roon.

@Jeffrey_Larson, if the Leviathan is disconnected from the Razer Blade 15, does Roon play to the Blade’s internal speaker/system output? I am trying to isolate the Leviathan from the chain and help you determine what works/does not work on the Blade. Do you also have the latest video drivers installed on the Blade?

Finally, on the Blade, do you have your W11 network settings set to Private Network, and firewall exceptions set for roon.exe and raatserver.exe?

Yes, if the Leviathan is disconnected Roon plays to the internal speakers.
I just tried it on a different brand new machine and it also does not work.
It uses wired ethernet, the network is set as Private and Windows Defender is disabled.
I’m not sure what video drivers would have to do with this but they are up to date.
Thanks for the response.

Does the Leviathan use any other control software from Razer to operate it, anything that runs in the background? I am wondering if this software may be interferring with Roon and the USB interface/driver on the Leviathan.

For example, a number of other users have USB audio interfaces for connecting as a DAC or driving active monitors (I use a Focusrite Scarlett for one connection). Many of these interfaces also have control software that provide enhanced features for recording, routing etc. Some Roon users also experienced instability or crashing of Roon, which stopped when they disabled the audio interface control software and let the native USB interface connect directly to Roon.

It does have control software called Synapse where you can adjust the lighting and surround effects.
That was installed on the original Razer laptop. On the new Intel NUC, I just plugged it in and did not install Synapse. So I guess it’s possible that it auto-downloaded some drivers but the usual control app is not installed.

Hi @Jeffrey_Larson ,

Apologies for the delayed response here. Can you please check the Device Setup for this zone → Advanced settings?

Sometimes headphones and sound bars only accept 5.1 input, I would try to see if you have the toggle to convert stereo content to 5.1/7.1 and if that plays.

If that still does not work, please let us know the exact local time + date + track of the error and we can enable diagnostics mode to look into the Roon logging, thanks!

Thanks for the response.
I ran a series of tests this evening starting around 8:41pm CST.

The first test I did with the Leviathan configured
as the default system output device in Windows.

The Roon device setup dialog shows:

Private zone: yes
Volume control: Device volume
Resync delay: 0ms
Zone grouping delay (ms): 0.00

For a test track I used Tidal and chose Fields of Gold from
the Eva Cassidy album Live at Blues Alley.

I selected play at 8:41pm 4/13. It started skipping through tracks
without playing anything until it gave up with “too many failures”.

Next, I enabled the Leviathan as an output directly in Roon
rather than going through the system output device.

The device setup dialog shows:

Audio Device: Unidentified device
Razer Leviathan V2 Pro

Private zone: no
Exclusive mode: Yes
Volume control: Device volume
Resync delay: 0ms
Zone grouping delay (ms): 0.00
Clock master priority: Default
Enable event mode: Yes
Work around devices that misreport capabilities: No
Buffer size: Default
Channel layout: 2.0
Multichannel mixing: Downmix as needed

I attempted playing the same track at 8:47, same failure.

I repeated this test with changes to each device setting
one at a time.

Exclusive mode: no
Enable event mode: no
Workaround devices: Yes
Channel layout: 5.1
with Send stereo/mono content at 5.1: no

Channel layout: 5.1
with Send stereo/mono content at 5.1: yes

Multi channel mixing: Channel mapping only

All failed. I didn’t try various combinations of those.

Next I brought up the manufacturers device setup control panl
called Synapse. Beyond basic options like volume and subwoofer level
it has an option called “Audio Modes” that can be Stereo, Virtual Headset,
Virtual Speakers, Room Fill. These all apply forms of DSP to the signal,
I did not seeing anything related to 5.1 vs. stereo.

None of these settings made any difference.

Thanks for your time,


I went back to Roon device setup and tried this:

Channel layout: 7.1
Send stereo/mono content as 7.1: Yes
Swap rear and surround channels: No

It worked!

I then went back to device settings and set

Send stereo/mono content as 7.1: No

It failed like before.

So the magic settings seem to be channel layout 7.1 and
send stereo as 7.1.

I went to the product page here:

and saw “Our advanced 7.1 surround sound delivers audio with pinpoint accuracy…”

So while this is just a sound bar and not a true 7.1 it may present
itself to the OS as a 7.1 device. What’s weird is that no other applications
seem to care about this and I’ve only attempted to play stereo content.


1 Like

A final comment. This does mean that you can’t use System Output with the default output device configured as the Leviathan because those two magic parameters aren’t available for the System Output
device. You have to output to the Leviathan device directly. That is not a problem for me, but it is a little confusing.

Thank you so much!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.