Topping USB External DAC - Digital warbles while using Roon Ready from Bluesound Node

Roon Core Machine

Win 11 Pro, i9-10580K, 64GB

Networking Gear & Setup Details

Wired, 1gb Netgear managed switch

Connected Audio Devices

PC --USB to SPDIF → Bluesound Node 3 --USB → Topping D90SE --coax–>Sony Amp --speaker cable–>Infinity Sterling

Number of Tracks in Library


Description of Issue

Instead of rewriting this I’ll copy the text:

I’m an IT professional so I’m generally pretty good at tracking down a problem.

Previous setup - current Node (I guess 3?) hardwired to the same network as my Roon Core PC, no issues with Nas library or Roon or Tidal/Qobuz etc - had some issues with Iheartradio podcast stopping short but don’t care too much there. Also have a PC run into optical in without a problem. Output is coax into 90’s Sony receiver pushing two Infinity speakers. No issues with this setup at all minus Iheartradio, but again not a big deal.

I got upgraditis and bought a Topping D90SE. Everything works great except for Roon Ready into the external DAC makes a horrible digital warbling every two seconds when the music gets louder it gets generally worse. I defaulted the D90SE to make sure nothing was off there, same issues. It plays from my PC okay, from Tidal okay, seems to just be Roon. I rebooted all equipment involved including the Core PC and still the issue. Roon from my PC plays fine in Roon and HQPlayer, but this is the Roon Ready in the Node which I use all day long and I really want to work.

So the screen that I’m familiar with that you can turn off the automatic clockrate is gone and the Node automatically sets fixed volume. I assume the clockrate is turned off. I can “Reset all” on the BlueOS Audio screen and I can specifically turn off the clockrate after I select the USB output but that doesn’t fix anything.

On the Topping I tried switching from PRE to DAC to no avail. I also noticed after I did that the Topping showed up as a device on my Roon audio screen but it won’t let me set it to that, I think I need to turn it back to DAC mode for that but everything I read said to run this on PREAMP mode. Really don’t know what else I can set on the Topping to fix this.

This feels like a BlueOS issue to me as everything else works but I don’t know how to fix it. My Roon Core is updated. My Node is updated. Are there any known issues with clockrate/playback issues since implementing external USB DACs? Is there an issue with the D90SE? I was pondering a Denafrips, should I send this back and get an Ares II/or 12th?

Their support linked me to this:


If you are using ROON and MQA with an external DAC, sending digital audio through the USB port of NODE (N130) may cause audio dropouts. In ROON please adjust your NODE settings using the following configurations:

  1. Go to ROON’s Device Setup screen for NODE.
  2. From the MQA capabilities drop-down, select Renderer only.
  3. Expand Show advanced and set the Enable MQA core decoder to Yes.

If you still encounter audio dropouts, use USB DAC implementation natively without ROON and reach out to ROON directly for further assistance.

Which brings me here. It feels like it is a Bluesound issue personally. It feels like clockrate is an issue.

Are you sure you are not clipping?
Do you see the clipping indicator turn red at anytime during playback?

I had tried turning on headroom management but I’ll try again. Does Roon show clipping in its color dot?

It does but this will only happen at all if using DSP if your not using any form of DSP then clipping in Roon isnt the issue. Show your signal path to the node maybe some pointers in it.

Still have problems when I turn off DSP, headroom to -7db and clipping red indicator is on. Not clipping, but glitchy chop outs are still happening

And I recorded the issues with my webcam which isn’t ideally facing the speakers but you can hear the issue clearly. Again, no clipping happening in this, I also did not edit the audio in any way:

Song is Hum - The Summoning, around 3:16 and plays back fine WASAPI from my PC into the node out the USB DAC

Are you saying this is happening with just one specific song or all the time?

All the time with every song, just included the song info to be I guess too precise

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.