Track skipping JDS Element connected endpoint

Roon Core Machine

|Processor|Intel(R) Core™ i7-6700K CPU @ 4.00GHz 4.00 GHz|
|Installed RAM|32.0 GB|
|System type|64-bit operating system, x64-based processor|

Networking Gear & Setup Details

Asus GT-AC5300
D-Link EoP adapter from router
100/40Mbps internet
No internet/network issues
Raspberry pi with Pi-hole on network
PIA VPN with Dedicated IP - Roon & RoonServer VPN bypass
Windows firewall allowed for private/public

Connected Audio Devices

RoPieeXL, Homepods, PC desktop (same Roon core + Roon app) , other mobile devices

Number of Tracks in Library

18,000 tracks locally connected to Roon core
Qobuz connected

Description of Issue

PC desktop that hosts Roon Core, I also use to stream via Roon app, unfortunately when I try to play audio from the desktop it skips tracks - both those that are locally stored and those that are streamed from Qobuz.

PC desktop has a JDS Labs Element enabled under “Audio” - WASAPI. Exclusive mode is enabled.

Frustrating

A few points of clarification

How is the Core connected to the Router , if not Ethernet can you make it so even just to test ?
Is this a Pi3 or 4
Do you use USB out
Do you use Ethernet in

Skipping is invariably a network issue , not necessarily your internet speed (for example mine is a meagre 20D/10U ) but your internal LAN. there a loads of examples of Power based shortfalls

Hi, thanks for the response.

Core is connected via EoP adapter to the router (works 100% fine - no latency, dropped packets, easily maxes internet connection & can stream 4k DTS-MA), although I don’t think this is anything to do with a network problem.

The logic behind it not being a network problem is that the Core is trying is failing at serving itself but is perfectly fine at serving other devices with EoP (e.g. the RoPieeXL), and other devices with Wi-Fi (e.g. the HomePods).

Just re-iterating that the desktop PC is the device with the Core and also the device that has issues serving audio, but can serve out everything else 100% fine.

But since you asked - the RoPieeXL is a Pi3 - again works fine. The Pi-hole is a Pi4.

The desktop PC uses USB out to the JDS Element. The JDS Element works perfectly fine with everything else except for Roon.

So, to summarise, all your other endpoints are working perfectly, but the endpoint that is the JDS Element connected via USB to your Core PC has the skipping tracks issue?

Some more information would be helpful for the Support team in diagnosis:

  • What, precisely, is the OS that you use on the PC?
  • Which model of the JDS Element are you using?
  • Are you using the USB cable supplied with the JDS Element, or have you swapped it for another?
  • Have you installed the latest version of the ASIO driver?
  • Can you show screenshots of the Roon device settings that you are using for the JDS Element?

Thanks.

That’s right

Windows 10 22H2

First one

Same

Not sure what this is

image


Sorry, I see now that the ASIO driver is optional, according to the JDS web site.

Couple of things you can try in Roon’s device settings:

  • turn on the “Work around devices that misreport capabilities”. If that doesn’t seem to help with the issue, then try
  • turning off the “Enable event mode” setting.

Thanks, unfortunately neither of these worked both on separately or together

OK, then perhaps the next thing to check is that you have the PCM sample rate and bit length matching what you have set up in Windows?

(while we’re waiting for a response from the Support team)

CaN you play to the pc’s system output?

Another interesting issue is that once I quit Roon, I have to restart the PC to get sound back as other software like Qobuz will say “The device is being used by another application”. I’m guessing Roon is playing up with the whole “exclusive” setting.

24-bit, 48000 Hz (Studio Quality)
Exclusive mode boxes are ticked

It doesn’t work if I select the “System Output” device in Roon, it still skips through all the tracks

Skipping through the tracks can indicatw that Roon can not get exclusive hold on the audio endpoint and fails.

Can also happen with out of date Realtek drivers. If you have realtek hardware, try updating to the latest drivers.

So how do I fix it, if it’s enabled on Windows and setting selected on Roon?
It makes sense to me that Roon is getting exclusive hold, because I have issues when I close Roon down - I can no longer get sound from other applications.
This sounds like a Roon bug? It keeping exclusive hold

That’s a very strange conclusion unless Roon has some weird behaviour different from all other software?

image
image

Appreciate the help given that it appears you don’t work for Roon, but is there a way to contact Roon directly? I couldn’t find anything on their website with an email, etc.

Posting in this #support category of the forum and filling out the post template with details of your setup and issue is the official way to get technical support. The Support team are automatically notified of all new posts in this category, and the post goes into their support queue. However, please bear in mind that there has just been a holiday period, and the team is small, so the queue can get rather long at times.

I notice that you said that skipping still occurs when you connect to the System Output of Windows. That would seem to point to an issue in Windows. What audio hardware do you have in your PC?

Personally I would bypass the EoP device and try wireless or I temporary long cable from router instead and see if that helps. EoP and Roon don’t always mix and they are known to be very up and down with performance. It may not be this, but for me the network is the first place to debug when you have streaming issues.

Why would it be a Windows problem when every other software works 100% fine… except Roon?
I’ve uninstalled/re-installed the JDS Labs Element driver. No change.

Other audio hardware:

  • ASUS Z170I Pro, whatever comes onboard with that - looks like “SupremeFX 8-Channel High Definition Audio”
  • NHDA through NVIDIA 1080
  • Yeti microphone input
  • Acer X34 monitor speaker output

Hello, Roon Support?

Hi @Akerow,

Thank you for your patience in awaiting a response from Roon. We are indeed catching up after the holidays and I’m trying my best to triage issues by impact.

I’ve taken a look at diagnostic logging and I’ll share both the relevant and irrelevant findings.

  1. There are quite a few network errors. Not that it would impact this specifically but thought you should know. A potential fix is to change the router DNS to Google’s or Cloudfare’s.

  2. Just after your last post, it appears some of the errors recognizing the device disappeared. Has anything changed on your side?

  3. Here is one of the errors I saw. Does the date and (GMT) time correlate?

01/04 18:09:35 Warn: [storage/streaming] [Qobuz] no tracks found for playlist id: 203:0:6586374
  1. Are you using any of Roon’s DSP settings? If so, does disabling DSP change anything?

Aside from trying to clarify the items above, one thing you can do is wipe Roon’s slate clean and I am going to list the steps below. Please be sure to back up before you do this. Also, please try to recreate the issue before bringing the DBs back into the equation.

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page

Please let me know your outcome. Hopefully, it’s already resolved and I typed all of this for nothing :joy:

Thanks,
Wes