Tracks in history unavailable...but they're there! how to solve?

Core Machine (Operating system/System info/Roon build number)

Intel NUC, Audio-linux, latest server build.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Synology NAS with audio files, ubiquiti throughout, wired with static IPs.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

Looking at my history, it is peppered with tracks that are marked unavailable. However, the file, folder structure etc is accurate when I ‘view file info…’. The file information is exactly the same in the history as it is in the album listing (where the track plays fine). From within History, I’ve tried using the ‘edit’ button and re-scanning, re-identifying etc but nothing seems to bring the record in history back to life. How can I solve this? Thanks.

Do you see any of these in Settings>Library>Skipped Files?
Maybe I don’t understand the question. Are you saying you can play this file from the album but if you try to play it via History there is an error?

Hi @crom,

Just to clarify here, are you able to navigate to and play these tracks just fine when you go to them outside of history?

Thanks for replies guys!

Yes, something that is marked unavailable in history can’t be interacted with (apart from the vertical elipsis on the right-hand side which tells me file details and also enabled me to try to edit as described above).

However, when I find the same file in the album listing (ie not in history) then they play just fine

Thanks Scott. I have seen that but I don’t think it’s my problem. That list is files that have been skipped during import. These files are very much in my library and play perfectly. however, the history list marks them as not there…which clearly they are. It’s really annoying as I often retrace my steps using the history.

Hi @crom,

Can you share a screenshot of Settings | Library | Clean Up Library? Note that you don’t need to run this process, we just want to see the numbers appearing here.

Sure…easier for me to write that share shot thogh:

3161 deleted files
11821 files that are not associated with a storage location
0 files associated with disabled storage location

Hmmm, good call. That doesn’t look too healthy does it.

I looked at this feature when it was first introduced and decided that I wasn’t happy using it because I’d like to see what it’s intending to do before it’s run. For instance, I know that there aren’t any storage locations that have been removed (ie my storage is my nas box and that hasn’t changed in years) and I’m concerned that the play data for almost 12000 files will suddenly disappear if I run this. I’d much rather be able to manually re-associate play data about specific tracks to the file.

In this instance, the file locations of the files that are marked as unavailable are exactly the same as the file locations indicated in the files that play perfectly well in the album list. I’m confused!

For whatever reason, there are a ton of files that aren’t where Roon thinks they are. And I’d bet that the reason they aren’t available in History is that the reference location for that file when you played it has changed.
What do you have for Settings>Storage?
Maybe it still is the same NAS box, but the IP changed at some time?
How are you set up for backups of your Roon Database? First, you definitely want a copy of that set aside before you make changes you regret. If you are fortunate (or lucky) you may have a backup of the database from a time longer back that you can query the storage location.

I have a similar configuration (just with Ubuntu server rather than Audio-linux), and I also have some “unavailable” tracks in the history that have been always in the same server and file location. All of my Roon networked components, and the NAS, have fixed IP addresses. No “unavailable” tracks in the last few months. I suspect one (or both) of two possibilities:

  1. Some minor corruption in the Roon database at some point caused by now updated software.
  2. The way tracks are identified in the history list involves some compressed/hashed descriptor of the actual track file that can get out of sync if the actual track file changes in minor ways (for instance, updated ID3 tags, creation/update date) even though the music bits have stayed the same.

Thanks guys, I have noticed in the past that the number of times I’ve played certain tracks has suddenly dropped or reset so perhaps that is also an indication that Roon loses track of tracks from time to time.

I am working at the moment but will do some deeper investigation and report back.

Hi @crom,

Based on that info, it looks like there are some files that we appeared to have lost track of and then were re-imported fresh. Have you made any changes to your watched folders or moved around any files or anything recently?

Thanks Dylan, yes, I guess that must be the case. No watched folder changes and files haven’t been moved around at all. Even network shares have been consistent since I lost my entire library a couple of months back.

Is there any way to edit these tracks that have been lost-track-of manually?

What does that mean? What happened when you ‘lost your library’?

I didn’t lose the music files but I lost the Roon library database. No idea what happened. I rebooted the roon server and after about 30 minutes Roon appeared with nothing in it! I restored from a backup but it was a few months old.

For the tracks that are missing in history, were they played before or after this event?

I’m wondering if either the lost library or something more insidious (that leads to your library being lost) could have lead to the missing tracks.

Hi @crom,

When did you first start noticing this in history? It appears that, at some point, at least one of your watched folders was re-imported newly by Roon.

This can happen if duplicate watched folders are added or if library migrations are done improperly.

Generally the best way to resolve is to restore a backup from before this behavior occurred.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.