Tracks keep skipping after ~90 seconds

Roon Core Machine

MAC OS 12 latest beta

Networking Gear & Setup Details

Netgear router connected to fibre optic (Mpbs 150) modem

Connected Audio Devices

DAC plugged into my USB-C on my MacBook Pro.

Number of Tracks in Library

~10,000 tracks

Description of Issue

The tracks skip every time about 60-120 seconds in. I am logged in using TIDAL. I tried refreshing Roon, rebooting. Latest Roon version. Re-logged into Tidal. Nothing has worked. When I play music on Spotify outside Roon it works fine.

Is the core connection to the network wifi? Try ethernet

what are the DNS settings in use… try or

what is a or indicating?

try restarting the network - ie power off the modem/router and anything else


Hey @Pascal_Tremblay,

We’re very sorry that your music listening experience is being interrupted by tracks being skipped. We’re replying substantially later than we had wanted — we’re incredibly sorry about the delay.

I was wondering though, is this behavior still happening?

@wizardofoz’s suggestions are on point. Did you get a chance to try any of them? And thanks a lot, @wizardofoz :pray:

1 Like