Tracks Not Completing and Skipping To Next Track

Core Machine (Operating system/System info/Roon build number)

iMac - 3.8 GHz Quad-Core Intel Cor i5; 8GB RAM
macOS: Big Sur Version 11.2.3
Roon version 1.8 (build 783) stable
Using Tidal with a MacBook Air as a remote running same build as Core on iMac.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Google WiFi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bluesound PowerNode 2i
Kef LS50 Meta Speakers

Description Of Issue

Tracks are not completing and then skipping to the next track. Was just listening to Talking Heads Remain In Light (24bit MQA 96kHz). Tidal is the service being used.

This just started this afternoon. I have rebooted both Core and Remote. I see others are reporting similar concerns.


Just happened again. This time while listening to Lana Del Rey Chemtrails Over The Country Club (24bit MQA 48kHz). This is not normal. This appears to coincide with the latest software update.

1 Like

Me too. Exact same thing. Roon Core on very similar hardware except mine is Mac-mini on Big Sur. Streaming to Roon Ready certified endpoint Monoprice HTP-1. Losing my sanity. Never had this issue. Restarted core and endpoint, re-enabled endpoint, etc, etc, nothing makes a difference. Streaming Tidal will play fine for several tracks and then skip in the middle of a track to the next track for no apparent reason. Everything wired. SMB grade networking equipment on 1Gb business grade internet. All started after my Roon updated this morning to 1.8 build 783. Ahhhh!!! Please fix.

Yes, I’ve been having the same issue since the update. I veh tried reboots, and performing the subsequent updates as well as the Apple updates to no avail. I even went into settings and tried to increase the time between playing tracks, also no change.
I use an Antipodes DX with a Mac and iPads to control playlists etc.
…and I also find it will play ok for a track or two, then revert to skipping to the next before the first has finished.

1 Like

Thanks, Robert and Tony.

I will also add that I have no issue playing the same music using Tidal Connect off of the Bluesound PowerNode. So, I’m struggling with those in other threads suggesting it’s a network issue or a modification of a DNS setting is necessary in order for Roon to work properly.

Definitely not local LAN, ISP and/or DNS related. I’ve been running Roon for the last year on the same setup and have never had this problem. Running the latest 1.8 builds with no issues until build 783. Started Roon this morning, received update notification on the iPhone remote app, hit update all, everything updated and then 3 songs in this nonsense started. I tested everything possible twice. Very random. Can sometimes play for almost an hour before it happens again. Something changed in Roon Core build 783 that’s dropping the Tidal stream. Authentication is timing out or something.

Updated to latest build yesterday and had the same issue, though only once. Did not notice it again for the next 5 hours. Roon core on MMM1, wired Ethernet.

Is there some way to get Roon support to weigh in here?

I have the same issue since the update

I’ve been having this issue constantly since the last update (build 783). Constant dropouts and skipping to the next track (sometimes even a few tracks ahead) on Chromecast Audio over Wi-Fi. No internet issues, no signal issues, and Roon behaved perfectly over this same setup just before the update.

I might suggest that everyone opens up a separate support topic on this in an effort to bring Roon Support to the table. Once they do respond to this, my assumption is that they will ask for that, anyway. Maybe a better chance of that happening if they see several new threads reporting this issue.

After extensive testing, I may have a solution:

  1. Disable the endpoint having the difficulty.
  2. Re-enable endpoint.
  3. Change random setting in device setup. Save.
  4. Reset to defaults. Save again.

Haven’t had an issue since. Been playing almost 4 hours without hiccups.

I’m not sure what exactly is the problem, but you have to somehow reset the config file for the endpoint. Even though I’ve never changed the device settings (they’ve always been on defaults), changing a random setting and then resetting back to defaults and saving again seems to have done the trick (you might not have to disable and re-enable, but I did to be safe). Hopefully, I’ve explained this clearly. Sorry in advance for any confusion.


Robert - I’ve followed your steps and will give it a try. I’ll report back after giving a few albums a try.

Thanks for offering a possible solution.

Good hope indeed! :+1:

Well, I made it through a whole album without it skipping, and that hasn’t happened since the upgrade. So off to a good start, but still nervous. If I can get through a couple more without issue, I might start to relax a little.

So it had been working flawlessly since I made the changes (removed my end-point, added it back, made change, saved, reverted the change back and saved)…until just now. It just did the same thing - stopped playing during a track and skipped to the next. Granted, this is the first instance in about 3 days, but frustrating none-the-less. I’m not going to make any additional changes to see if this was just an anomaly or a recurrence of the issue as it was before.

I’ve been having this problem frequently since 1.8, and seldom before that. It happens with Tidal, usually MQA files, but not with Qobuz. I have changed nothing in my network. I have tried all recommended public DNSs (Google resolved things for me when this happened with early 1.8 builds, but no more). I’m going to try the suggested fix tonight. I sincerely hope it works because I live in fear of the typical Roon “change to a better router” solution. I’m in Brazil with decent 400 meg fibre internet that has good, fast backbones to N. America and Europe. But the supplied modem-router has bridge mode disabled by the provider, so a better router (which I have on hand) isn’t possíble. Many, including me have tried and all have failed.

Hi @James_McKeand,

Thank you so much for creating this thread and sharing the details of your setup, as well as for discussing this real matter with other Roon subscribers. By the way, we do appreciate everyone’s input :pray:

I am sorry for the trouble you, @James_McKeand and everyone else, have ran into when streaming music from TIDAL via Roon. As it was alluded to, there were a few instances when this combination didn’t work quite well. Since then, this seems to have been resolved.

I know it’s been way too long since this conversation started and we’ve barely stepped in now. Please, accept my sincere apology :pleading_face:. It’s not from lack of trying - we are actively working to reply to everyone, but response times aren’t what we want them to be.

Has this happened since, @James_McKeand ? We’d love to help :nerd_face:

Thanks, @rebeka . Things have recently been working well for me and my setup. A couple of things have occurred, so I’m not sure which has been the primary resolver for me.

  1. Bluesound had a software update for its Powernode 2i (my streaming amplifier).
  2. There has been at least one Roon update since I reported my problem (now on Build 790 vs 783 when I started this topic).

I think much of the problem went away with the BlueOS upgrade - but, again, I’m not completely sure. It is possible that it was a combination of the Bluesound and Roon changes (I made no changes to my network or system other than the software updates mentioned) that improved performance.

I will certainly report back if I encounter any similar issues moving forward. Thanks again for responding.

I concur. Build 790 solid.