Tracks Skipping or Terminating Early

Core Machine (Operating system/System info/Roon build number)

Win10 PC, Core I5 Processor @ 2.4ghz, 8Gb RAM, 500 Gb disk, attached 1TB USB SSD with FLAC library

**Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet

Ethernet LAN using CAT6 cables, Netgear switches

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Naim Uniti Atom, LAN connect

Description Of Issue

I’ve reported this issue to Roon previously when using v1.7 and a very helpful lady from Roon Support offered me a solution that has worked until 1.8 was installed. Every track I play via Quboz or FLAC from the SSD connected to my core PC either skips soon into the track or skips completely.

To eliminate a networking or PC issue, I’ve played the same FLAC files from the SSD over my LAN using Asset UPnP server with no skipping at all.

To eliminate a Quboz issue I’ve played hires tracks in the Quboz app on my PC. I also detached Quboz from Roon and re-connected to no avail.

I can play the same FLAC files from the SSD via the USB on the Uniti Atom, and Quboz natively on the Atom, also via Airplay with no issues.

The previous advice that worked was to restart the core and all nodes, disconnect Quboz and reconnect and alter the DSP Headroom Management (i changed from -3 to -5 in v1.7, which worked). I’ve since increased this in increments to -10 to no avail.

Can anyone offer any advice on what I may have missed or what is going wrong in my Roon 1.8 settings? Roon is unusable for me. Thanks.

Hi @Ross_Dorgan

Does the same behavior occur if you play to System Output of the PC instead of the Naim?

If you disable DSP completely (as a test) is there any change?

Hi Dylan, thanks for your suggestions.
If I play system output on the PC there appears to be no skipping.
I reset DSP to default (all settings off - I assume that’s disabled?) and skipping still occurs on the Naim, this is a 24/192 FLAC file by the way. However the same file played across the same network to the Naim via dBPoweramp Asset server the file plays fine, no skipping.
Another interesting point, I don’t know if it is relevant, when I start playing the file/track on Roon I timed about 7 seconds before the track actually gives any output to the Naim, then it skips the track after about 5 seconds and skips some tracks completely. There’s no delay (or max 1 second) when playing via system output.
Any other guidance would be welcome. The interface to my Naim used to be fine by the way, after I logged the previous ticket I referred to. Roon has updated since then, don’t know if that is relevant.

Hi Dylan,
I’ve done some more testing and sorry but I got confused with which versions I have been playing.
The track skipping is actually a 24/192 Quboz file, I tried other 24/192 Quboz files and they are skipping the same.
So I searched my library for a 24/192 file and selected Bruce Springsteen’s Nebraska. This plays well now on the Atom. The 24/192 Quboz version of the same album does not, it skips. It also takes a long time to start playing before skipping.
Playing the same album via the Naim app in native Quboz mode on the Atom, no skipping.
Playing the same as system output via Roon on the PC, no skipping.
Playing the same on the Quboz app on the PC, no skipping.
I’ve tried again disconnecting Quboz from Roon and re-connecting, no change unfortunately.
DSP has been turned off through all of this. So then I tried playing the Quboz file with DSP headroom management on, no change.
Sorry again for the initial misdirection and I’m hoping some of this helps you itemise the problem better?

Hi Dylan, is there any further update on this please?
Quboz 24/192 files are skipping, this was not a problem before v1.8 after my previous support ticket.
Quboz 24/192 will play on my Atom in Naim native mode, but not from Roon.
I bought Roon to consolidate my stored FLAC files with Quboz, at the moment I can’t use Roon and have reverted to playing from the Naim app and upnp via dbPoweramp, but this is less than ideal.
Thanks for any suggestions.

Hi @Ross_Dorgan

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

Please note the exact local time + date when this issue next occurs and the name of the track that was playing and upload your Roon Logs by using these instructions. The best way to get them over to me would be via Dropbox / Google Drive, but if you don’t have either service please let me know and I can provide alternate upload instructions.


The same issue continues to happen for me as well - it would be great to receive an estimation from @support as to when the problem will be resolved.

1 Like

I’m having the same issues.

My Server is running on a Synology 920+ with 2x SSD nvme caches
My Players is a RPi 4 running HiFi Berry OS with a HiFiBerry DAC+ Pro

Here is a gist with the server log from some skips. It happens both in TIDAL & Local files

1 Like

Hi Dylan,
Thanks for getting back, My issue now seems to be fixed.
I moved my core PC into another room temporarily as I was cleaning and removed the external SSD in the process.
At that point I also got a software update message (build 790) and I updated the core and all my remote devices.
Playing Roon after that the skipping stopped.
I’ve since moved my core back to it’s original location and re-connected the SSD, still no skipping.
I’ve also since disabled DSP headroom management and it remains stable, no skipping.
So I’m not sure what actually fixed the issue, I wondered if the skipping was occurring due to re-indexing of the SSD going on in the background or it could have been fixed by the software update (although nothing mentioned in there on bug fixes).
Long story short, I’m enjoying Roon again!

1 Like

hi @Arthur_Soares,
I’m just interested in your configuration because I also wanted to buy a NAS for the roon core.
Your roon core is runing on the server (Synology 920+) with how much RAM?
Do you use M.2 SSD for the roon core on the NAS? If yes, which one?
I thought the hardware requests for roon are higher and wanted to buy a Qnap TS-473 with 8GB.

I thought so far that only people with Mac or PC for the roon core are affected by this issue.

My 920+ has

  • I have two 500GB M.2 SSDs for Read and Write Cache.
  • 8GB RAM
  • My RAM usage with a couple of Docker images, Plex Server, and Roon server stays around 58%
  • Roon Server is responsible for 2.8GB of it. Even when idleing.

Roon really offers an amazing range of features, but the software side is completely :-1: . I have constant iOS crashes (iPhone 11 Pro & iPad Pro), etc…

Hey @Arthur_Soares,

Thanks for joining in on this thread and sharing your similar experience. I’m sorry about the trouble!

So our technicians can best help with your specific issue, would you mind creating your own thread using the article below as a guide?

Thanks in advance :pray:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.