Tracks stutter when streaming to Sonos

Roon Core Machine

  • PC, Windows 11

AMD Ryzen 7 5800X 8-Core 3.8 GHz



Roon version 1.8 (build 903)

Networking Gear & Setup Details

Netgear Orbi router.

Connected Audio Devices

  • The PC, hosting the Core, is connected to the router via ethernet, as is the Sonos output device.

The PC and Sonos output device are connected to the router via the same unmanaged Netgear switch.

The Dac is a wired connection between PC to DAC to Sonos line in

Number of Tracks in Library

333 tracks

Description of Issue

When playing tracks to either of my Sonos Amps, they frequently stutter; this applies to tracks that are streamed from Qobuz and also with tracks that are locally stored on my PC. It happens on approximately 90% of tracks that are selected and it is seemingly random which tracks play without stuttering. It doesn’t matter if I use a Roon remote or play from the PC where the Core is.

I have no issue playing tracks if I bypass Roon completely and play through Sonos directly.

The steps I have already taken, are:

clear cache in Roon

Assign static ip addresses to the Roon Core, and the Sonos output device

Reboot Roon Core

Reboot Rooter

Clean up library

Background audio analysis speed changed from throttled to 8 core

Profile deleted and new profile created

Changed the wireless channels on the Sonos app from 11 to 6 to 1

I have also played the tracks to the DAC and the Chromecast device. In these cases, there is no problem at all, indicating that the issue is in the transport between Roon and the Sonos Amp.

I have changed the Maximum bit depth on the Sonos Amp to 16 bit. This did not solve the problem.

However, I have changed the output device to Sonos Amp via Airplay rather than via Sonos Streaming and this did work.

What I can’t work out is why there is stuttering when streaming to the Sonos Amp via Sonos Streaming.

Any ideas much appreciated…

What is the DAC?

It’s an Arcam DAC but I don’t think that’s causing the problem because the DAC works fine. The issue is when streaming direct to the sonos amp from Roon.

OK it’s just from your post it sounded like you were going through the arcam to the sonos.

Does anyone know how to get someone from Roon support to help?

Many thanks

Hi Alan,

sorry for the late reply, we are looking into your log and will get back soon.

Hi @Alan_Russell,

Let’s have you go back into Settings>Library>Background audio analysis speed>and change to off. Then set On-demand audio analysis speed to Throttled. That will put less strain on your system resources. It will only be a slight improvement because your library appears to be rather small.

Also check your orbi router to see if this recommended setting from our Network best practices article is set correctly.

Netgear Orbi Routers: If you’re making use of an Orbi router, we recommend unchecking Disable IGMP Proxying in your router’s settings. This setting can interfere with the ability for Roon Remotes to connect to the Roon Core.

Additionally, do you feel any particular aversion to using Airplay over the Sonos Streaming option? Sound quality is indistinguishable between the two and Airplay seems to be working for you.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.