Tranfer the the music from usb drive to internal SSD Nucleus +

How I can tranfer the music from external usb drive to internal ssd in nucleus+?

Connect to both as network shares from a PC and copy across or mount the USB drive on the PC, share address is in below

thank you very much for the answer.
I can see the internal storage of Nucleus+ and the folder of the external drive on the web but I don’t know how copy the music folder in the internal storage.

Just to confirm that you have two disks in the Nucleus. The OS disk and a storage disk?

I don’t know answer …
I purchased the new Nucleus+ and I connected an external USB HDD with the music files. Since the noise from the external disk was annoying I purchased a 2TB SSD, I installed it in the nucleus+ and I formatted it according to the manual procedure.
Now I see them both but the inner one is empty. I would like to transfer the old external HDD files to the new internal SSD.

Ok. Do you have a PC either a Mac or Windows you can use?
If so you connect to both drives and use file copy.

PC Win10 64 bit

I’m trying to do this but I do not have the copy and paste option.
I can see the two units close together and that’s it

The Internal Storage that’s added to your Nucleus is formatted in the Ext4 file system and thus unreadable when hooked up directly to Windows or macOS. You can read and write to it over the network though. This would be your best route:

  1. Hook up the external drive to your Windows system
  2. Make a network connection to the Internal Storage drive on your Nucleus: smb://nucleus/Data – you’ll see InternalStorage in the Storage folder
  3. Make sure Roonserver is stopped from the browser interface of your Nucleus (http://nucleus), so Roon does not start identifying while you are copying
  4. On your Windows system, copy your music from the external drive to InternalStorage on the network share. (Do not copy everything at once, but take a few folders at a time and see how it goes)
  5. When done copying, restart Roonserver from the Nucleus web interface
  6. If all goes well, Roon will start to reidentify your Music from InternalStorage. If not, check that Internal Storage is enabled in Roon Settings > Storage
  7. When all is done, disable the External Drive in Roon Settings > Storage

Good luck!

I did not understand and I do not know how to do the following step: “Make a network connection to the Internal Storage drive on your Nucleus: smb://nucleus/Data – you’ll see InternalStorage in the Storage folder”

Rene - if Antonio is using the Windows File Explorer, he should access this by typing in \\Nucleusplus\Data into the Explorer address field…

1 Like

I can access through this: “file://nucleusplus/Data/Storage/InternalStorage/”
to see the internal storage of the nucleus plus through browser but I can not put the files I have in the usb drive.
The PC and the nucleus do not communicate.

You need to map the Nucleus hard drive to your PC. Here’s a link to describe how. Your PC will see your Nucleus drive and then allow you to map it as a “shared drive.” At that point, it’s pretty easy to copy items from one drive to another. See screen capture below:

Michael, you don’t need to map the Nucleus hard drive to your PC; it can be accessed directly over the network, as done here for my ROCK NUC (my DIY Nucleus).

Antonio, don’t use your web browser to communicate with the Nucleus ( you wrote: I can access through this: “file://nucleusplus/Data/Storage/InternalStorage/” - which is what you would put into a web browser)

Use the Windows File Explorer to communicate as I show above…

You use the web browser to access the management web page functions of the Nucleus - not for moving files around…

Thanks for the clarification, Geoff.

You might also have to enable the SMB1 file protocol in windows …

1 Like

Magic, finally works!
I thank everyone for the help you have given me and for the patience shown. Without you I would not have made it. :))


Now backup your roon database :wink:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.