Trouble accessing Tidal and Metadata improver

Core Machine (Operating system/System info/Roon build number)

Win10 Pro/intel Core i7 vPro 7th Gen 8GB RAM/1.6 build 416

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

D-Link DSL 225/ Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bluesound Node 2i connected to same D-Link with Ethernet

Description Of Issue

Even though I can successfully log in to Tidal through Roon and see previously synced tracks from Tidal and local library, new tracks added to favorites through Tidal do not get synced - I’m getting an error that the Metadata improver is halted…
Also, when I try to see my Tidal Favorites through Roon I get “failed to load albums” or artists or tracks,

On the other hands I can see and play all the Tidal tracks that are already imported and synced through the main Roon library (not the Tidal tab). Not sure how I got my previous Tidal tracks synced, but now I can’t sync new ones into Roon.

I tried all the tricks and tips I found on the forum with no luck.

Please help :slightly_smiling_face:

Hi @Marc_Stern,

Where are you seeing this error, inside of Roon? I have not heard of this type of error before, can you possibly share a screenshot by using these instructions?

Can you please check to see if you are able to locate your tracks on the TIDAL web player ( Do they all show up normally there?

Hi Noris,
Tidal is working fine for me outside of Roon,

The errors I’m getting are all within Roon.

Attached screen shots:
Recent Tidal album I added is failing to sync to Roon library due to Metadata inmprover:

This is what I see when I go to Tidal in Roon:

What version of roon are you running? Settings, about.

Hi @Marc_Stern,

Is the Windows 10 running the “All-in-one” version of Roon or is it controlling a different Roon Core?

Can you share a screenshot of your Roon Settings -> About tab? The about section is located in the top right-hand area of the settings page.

1.6 build 416

The windows 10 is running Roon Core.
I control it with an iPhone

Hi @Marc_Stern,

Thanks for sharing that screenshot. It does indeed look like everything is up-to-date on firmware.

I wonder if the logs contain any additional information, can I please ask you to use these instructions to upload a set of logs from your Core? The best way to get them over to me would be via a shared Dropbox / Google Drive / link.


Here are my logs:


Hi @Marc_Stern,

Thanks for sending those log files over. I am taking a look through them and noticed quite a few network errors, are you by any chance on a corporate network which restricts access to certain websites/services?

Yes I am using a corporate laptop but it is connected to my private home network.
Also, I have no trouble accessing Tidal directly (not within Roon) using this computer when at home or even when I’m at work connected to the corporate network.

Hi @Marc_Stern,

I understand that TIDAL itself works as expected, but I am seeing quite a few proxy-related errors. From the logs you submitted it appears that your PC has issues communicating with our account servers due to this proxy.

I suspect that the last time TIDAL was able to properly sync, this proxy was not active and which is why you are seeing part of your TIDAL library from the previous sync.Is there any way you can temporarily disconnect from the Corporate network proxy or temporarily use another PC to host the Roon Core?

Hi Noris
I have already done that :slightly_smiling_face:
I migrated to another computer before contacting you for support and indeed everting worked fine and Tidal was accessible.

After verifying this I migrated back to the main computer that I need Roon to work on

How can the proxy issue be worked around?

Hi @Marc_Stern,

I’m not quite sure. As I mentioned, it appears that the proxy is blocking Roon access to our account servers, TIDAL servers through Roon and even servers which handle automatic audio configuration settings, this is not a good thing…

I have created a case for you with our QA team and have asked them to review your logs + this case info, I will let you know once I hear back from them. In the meantime, you may want to reach out to your corporate system admin to ask them if there is a way to allow Roon past this proxy as it does seem to be the source of the issues in your setup.

Can you provide the address of the Roon servers so that I may ask our IT people to check it out?

Hi @Marc_Stern,

There isn’t one specific address that Roon uses, but quite a few that need proper access from your Core. If there is a way to set exceptions on an application-level that would probably work best, but if IT has it set up on a per IP-address that would be a bit more difficult. Let’s see what QA says first before going down this route, I will let you know once your case has been reviewed.

Hi @Marc_Stern,

I spoke to the QA team and they have noted that this issue is indeed likely due to the proxy service on your corporate PC and it is causing issues with Roon.

They have suggested that you reach out to your corporate IT staff and see if there is a way to create an exception for Roon on an application level, as we cannot specify individual Roon server addresses.

If setting an exception on an application level is not possible, you will then unfortunately need to use a PC that does not have these proxy restrictions. Thanks for your understanding here!

Hi Noris,
Thank you for checking it out.
I’ll see what can be done on my side.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.