Trouble adding radio stations

Hi

I havent used the radio player for a while and started trying to add stations in. A few work however most just give the “cant find a station at this address” error. I cant even add BBC stations (yes I have a dns service to get round the geo block) but even the low rate BBC doesnt work.

Whats the issue?

Hazarding a guess, but it may be your dns service? I’m not seeing any problems here with low rate BBC streams that are not subject to the geo-block (I’m based in the NL). E.g.

http://a.files.bbci.co.uk/media/live/manifesto/audio/simulcast/hls/nonuk/sbr_low/ak/bbc_radio_three.m3u8

Unfortunately it is a Roon issue, all the streams work fine in J River

I have moved your post to the Support section, so it will receive attention of Roon @support.

Roon and J River obviously do not work in the same way. To give Support something to work with, you may want to expand a bit on what ‘DNS service’ you are using to circument the geoblock. (I’m not sure if Roon will support this scenario, but that’s not my call).

Just to be clear: when you disable the DNS trickery completely – does the low bitrate URL that @Geoff_Coupe posted above work?

Hi Rene,

Sorry but this has nothing to do with the DNS, I have already tried disabling it and using my ISPs normal DNS servers. Same problem, and as I stated in the OP the low bit rate (non geo locked) BBC streams dont work. Also this hasnt been exclusively a BBC station problem, many stations are coming up with this error.

BTW I have used this DNS service (Getflix) for several years previously without issue with Roon. Its only the past few months where I havent been using radio and just decided to put the stations back in. Roon doesnt need to “support” the DNS service, it just tells the other end my IP is in the UK and should be transparent to Roon. No matter, if Roon used to work fine and J River still does, then something is broken :slight_smile:

Other thing to mention I am running Roon Server on my Synology NAS at the moment (everything else works perfectly).

thanks

Alan

Log snippit

GetNewChannelData(http://a.files.bbci.co.uk/media/live/manifesto/audio/simulcast/hls/nonuk/sbr_low/ak/bbc_radio_three.m3u8)
06/11 11:37:41 Debug: [radio] Treating this as a stream URL
06/11 11:37:41 Trace: [internetradio] Channel Player: Fetching URL [http://a.files.bbci.co.uk/media/live/manifesto/audio/simulcast/hls/nonuk/sbr_low/ak/bbc_radio_three.m3u8]
06/11 11:37:46 Warn: [internetradio] Channel Player: Bad URL [http://a.files.bbci.co.uk/media/live/manifesto/audio/simulcast/hls/nonuk/sbr_low/ak/bbc_radio_three.m3u8]: Sooloos.Audio.ChannelHttpRequestException: Error Connecting to a.files.bbci.co.uk:80 —> System.Net.Sockets.SocketException: Could not resolve host ‘a.files.bbci.co.uk
at System.Net.Sockets.TcpClient…ctor (System.String hostname, System.Int32 port) [0x0006d] in <126998f2e5ae42fe95554117eb649feb>:0
at Sooloos.Audio.ShoutcastHttpRequest.GetResponse () [0x00012] in <9356f966dd1f4f278c03bfdff9694828>:0
— End of inner exception stack trace —
at Sooloos.Audio.ShoutcastHttpRequest.GetResponse () [0x0006d] in <9356f966dd1f4f278c03bfdff9694828>:0
at Sooloos.Audio.InternetChannelUrlProcessor+<>

The HD streams are working fine in the browser interface.

Hi @BE718 ---- Thank you for the report and sharing this observation you have made with us. The feedback is appreciated and sorry to hear of the troubles.

As with others in this thread, I tested the URLs listed here (i.e from the log traces) and had no issue loading/playing the internet radio streams. To help aide in our understanding as to why you are experiencing a different behavior, may I very kindly ask you for the following:

  • A brief but accurate description of your current setup using this link as a guide.

  • While it may seem a touch elementary, since noticing this behavior, have you not only rebooted your Roon core machine but also any networking hardware relevant to your Roon setup (i.e router, switches, etc)?

-Eric

As a data point, I just loaded

http://a.files.bbci.co.uk/media/live/manifesto/audio/simulcast/hls/nonuk/sbr_low/ak/bbc_radio_three.m3u8

as a Roon Internet Radio station and it was immediately found as a station and played music.

1 Like

Sorry I havent had much time to update this issue. However it does appear related to the Roon Server running on my Synology DS3615xs. I shut the server down, unauthorized it and set up a second version on another computer. This finds the stations OK.

So, its either something to do with the NAS itself, or that particular version of Roon.

1 Like

Thank you for the update @BE718 and no apologies necessary. The continued insight is appreciated!

I am glad to hear the mentioned test has yielded a positive result and things are working as expected in regard to adding radio stations with the Roon core being hosted on another device. I am curious, is there anything different in the way the NAS is communicating with your network versus the computer used during the test? Just trying to understand if any variables are different.

-Eric