Trouble with Sonore UPnP Bridge & Roon

I have just purchased a Vortexbox Mite running SonicOrbiter OS. I am intending to use it as a Sonore UPnP Bridge so that Roon can control the music on my Naim streamer (NAC-N 272).

Here is what I have done so far:

  1. Mite is connected via ethernet direct to my router and is powered on

  2. My Naim streamer is also connected via ethernet to my router

  3. From Roon I have enabled Squeezebox Support

  4. I opened a web browser and went to www.sonicorbiter.com but it did not detect any devices. So I found the IP address of the Mite and browsed to it directly.

  5. From the Nova page I went to Settings > Sonore UPnP Bridge

  6. The Bridge does not detect my Naim streamer as there is nothing to select in the “Available Renderers” list

  7. I’ve tried rebooting the Naim just in case

For clarification this is a AudioStore UK product and not produced by Sonore. What you can try is to refresh the page and see if it will rescan the network. Also, go to Apps / SonoreUPnP Bridge and se what the status is there.

I have refreshed the network scan and rebooted the Vortexbox Mite, it still does not detect anything.

The Sonore UPnP Bridge status says:

SonoreUPnP Bridge Version: 1.0.14

Server type: Bridge not running

Server IP: Bridge not running

Renderer: Bridge not running

Issue resolved by uninstalling and reinstalling Sonore UPnP Bridge app on the Vortexbox/Audiostore Mite. After the reinstall, the bridge successfully detected my Naim 272 and also my LG TV.

In Roon I went to Settings > Audio and then I could see SqueezeBox > SqueezeLite

I have another issue . . . two actually.

Every time I start to play music, i.e. a new album this volume goes to maximum on my streamer. Roon is set to Fixed Volume. I don’t want to control the volume through the Roon app as its too easy to go too loud or too quiet. My hifi has a remote control which is much better to use.

The second issue occurred as I was trying to debug the above. Roon refused to play any music and kept repeatedly skipping to the next track. Selecting a new album or playlist would also keep skipping to the next track without playing any music. I had to restart the Roon Core to stop it. After the restart, the Sonore UPnP bridge has now disappeared from Roon altogether so I am now sitting in silence. :cry:

Just to confirm my setup is:

  • Roon Core on mac mini
  • Roon Player on iOS
  • Sonore UPnP Bridge running on an Audiostore / Vortexbox Mite
  • Streamer is a Naim NAC-N 272
  • Everything is connected to router via ethernet cable (other than the iPad of course)

Quick update… I have been using Roon as much as I can over the weekend and haven’t had the skipping issue at all. Not really sure why, so fingers crossed that is resolved.

With fixed volume the digital volume is 100% so playback is bit perfect and you can control the volume elsewhere in your system.

What I mean is, the volume is being set to 100% on my Naim pre-amp/streamer by either Roon or the Bridge. I don’t want to control the volume in Roon. Nor do I want it to control the volume on my hifi either. As you can imagine it goes pretty loud and risks damaging my ears/equipment.

What you describe of controlling the volume on my hifi is exactly what I want.

I find the volume resets to 100% if I change certain settings such as enabling FLAC compression.

That is the fixed volume command being sent down the UPnP pipe line.

I’m not sure I understand what the point of this is.

If I choose Fixed Volume, that means I want to control volume on my hifi instead of Roon. If I choose Use Device Controls then I want volume changes in Roon to be passed through to my hifi. I want the first option.

Roon/Bridge should pass through Fixed Volume so I can then use the volume control on my Naim.

However, what happens (initially) is that Roon/Bridge tells my Naim to go to 100% - surely this is not the intended behaviour.