Trying to change a profile picture, getting a "network error"

Roon Core Machine

Windows 10 Desktop Roon Client

Description of Issue

I’m simply trying to edit the profile picture of my main profile, and getting this network issue. I’ve tried to search the forums for similar issues, only things I say mentioned rebooting, which I’ve done. I don’t understand why uploading a photo from a local hard drive to just be a profile would even require a network, but here we are.

Is it a PNG file extension?
This appears to be problematic for others.
Have you tried a jpg or anything other than PNG ( if it is a PNG you are trying)?.

Yeah, it was a png. I tried a jpg, same issue.

Very odd, I tried a few different format myself on my profile picture and all loaded just fine apart from the PNG and when I tried to use a 8.2mb jpg ( which gave an honest error description of file too large).

Anything else was ok.

However I was loading them from the same drive location as the Roon Core so not sure if that makes any difference?

Same problem here. Odd thing is that i dont see any error in the logs.
I have tried both png, jpeg and also past from clipboard.

same error on android client as well as windows 11 client.

– Update!

I converted the picture to GIF, and it worked without any problem!

I have the same problem.

If profile image has not been set, Roon seems to use my profile image from
In my case, if I delete the image, I was able to change Name field without any errors.