Trying to integrate Roon, Sonictransporter, MR and kef ls50w ..2 zones vs just 1? [Solved]

hi guys.

see 3 screenshots at bottom if you need visuals please.

my setup…sorry but could really do with your imput.
i’m probably making things more confusing than they need to be.

using apple ipad mini 4 and newly arrived sonictransporter i5 to replace my 10 yr old laptop.
also have MR and lps 1 power supply that i have attached to the sonictransporter.

zone 1: living room: just received my kef ls 50w speakers for living room/tv. (not yet set up)

zone 2: kitchen
so in my kitchen/desktop(25 ft away from living room) is the sonictransporter, mr and lps1 power supply. and sonos play 3.
sometimes i’ll use my hp amp or mojo and mr/lps 1.

but here is where i’m confused:

seems i have made up 2 zones: ipad and kitchen.
but i guess i should make living room a zone for my kefs: so change it from ipad.
probably a mistake and confusion i’m creating here.

in the ‘signal path’ for Roon I can see the sources but no sonictransporter (see pic at bottom)
bit depth
smaple rate
output (sonos)
but i can’t see the sonictransporter.
but the sonictransporter does show when i go into Roon settings…i can see it
as a ‘core and with an ip address, too’

also should i just get rid of the 2 zones and move it all to the living room?
i’ve read that a music server (sonictransporter i5)
is often best kept in a separate room so to reduce noise issues.

Hi j_c,

Nothing really wrong here.

Your SonicTransporter doesn’t show up in the Signal Path because Roon doesn’t describe the computer the Core is running on, just what is happening to the content and the Output.

In Settings/Audio you should see a section labelled “Connected to Core” which will show Outputs directly connected to the SonicTransporter, as distinct from Network zones connected by Ethernet:

The KEFs don’t show up because they’re not set up. Roon will see them when connected by Ethernet as follows:

If you own a pair of LS50W’s note that you will need to be using the newly released Firmware 1.1.464, and we recommend connecting your speakers over Ethernet, as opposed to Wifi. Once your speakers are on and set to “wireless” mode, you can enable them in the Audio tab of Settings. If you are having problems connecting to your LS50W’s, please confirm the KEF app is closed.

Also, note that due to the technical details of KEF streaming these speakers are not Roon Ready, so linking multiple pairs of LS50w is not possible and some RAAT-specific functionality (like convenience switching or advanced Signal Path functionality) is not possible

The Sonos devices will show up when connected and powered up.

The mR will show up as a Network Zone when connected by Ethernet to the router and Roon Ready app is selected in the web interface. It might also need something connected to it by USB to it in order to be discovered.

You can rename your iPad Zone as “iPad” or whatever else you like.

The only wrinkle I think you’ll find is if you were wanting to group the KEFs with the Sonos as a single Zone. Sonos will only group with Sonos and the KEFs won’t group with anything else.

Check back further as you hook things up, but I think you’ll find everything shows up in Roon as you power it up and connect it.

You can group the KEFs and Sonos devices by using RAAT endpoints in front of them, but you don’t need to worry about that if you are happy to have them as separate Zones playing separate music.

the sonos was to be in a separate kitchen zone…was not to be in the living room zone with kefs

below is a pic of my settings in audio… followed by 2 more pics of playback and general settings

.i don’t see the same screen outlay that you shared in one of the pics
…wonder how i can tweak it so i can add apple device…

or do these settings look ok to you?

a few more questions please andrew (hopefully this can help other newbies with a sonictransporter and mr/roon etc)

questions …
both MR and sonictransporter get plugged into the router…correct?
and is it suggested to separate the sonictransporter…keep it in the kitchen/other room, not in living room
due to noise transference etc?
thanks mucho btw!

cleared cache…got ‘roon has lost control of the transport device’ when deactivating dsp
hmmmmm…wonder if i should tweak something in my settings then

Sure. I was just talking about grouping them temporarily in order to play the same content through both.

You can take a screenshot on your iPad by pressing side and front buttons at the same time. Makes it a bit easier to upload.

The SonicTransporter isn’t exposing any direct connections, which is fine. It’s meant to be primarily a network player. It may be that if you plug a DAC into it by USB and select USB input then a direct USB connection will appear in Roon, but you don’t need to do that.
I give the iPad a 0.1s resync delay, just because it’s WiFi. I’ve left Max Sample Rate and Max Bit Rate disabled because I’m just playing back through the iPad speakers. You might use those if you are connecting your iPad to a DAC and don’t want to exceed it’s input parameters.


Yes. That is best practice.

1 Like

Thanks, as always, Andrew.
i’ll give you a sales plug: as soon as i set up the sonicorbiter and the clicked on the MR and sonictransporter
it was a breeze…i’ve had initial sync/setup issues with the MR by itself…but when the sonictransporter came on board everything booted up so fast and painlessly.
continued success with small green computers.

1 Like

drag…now i’m getting some intermittent sonos connectivity issues;
'‘roon lost control of the transport device.’

If they are on wifi it’s probably a bad signal or marginal one. Try on a lan cable or closer to a wifi app and see if that helps…could be other wifi devices hogging the channel too, or interference from another electrical device

Cool. I’ll drop a flag for @agillis, he’ll be pleased to see that.

lol…oh my i thought you were gillis (had forgotten his last name until you just mentioned it in the reply)…
.thought he had seen this and came on to assist given it’s his product…regardless i do appreciate your help.

Thanks for the plug!

The sounds like a Wi-Fi problem. There are some amazingly bad Wi-Fi routers out there many were designed for email and web browsing and do not work well for video or audio streaming.

Also most of the “Wi-Fi extenders” out there are half duplex and reduce your bandwidth by a factor of 10.

I have been recommending mesh networks. They improve network performance and lower latency. Great for both video and audio streaming.

1 Like

Andrew Gillis, can you please explain what. “Mesh network” is?

Just Google:

It’s a way to increase the strength of your WiFI network without using WiFi extenders. WiFi extenders don’t really work for anything but super low priority traffic like email.

I really like the Netgear Orbi but the Google Mesh stuff has also worked for some of my customers.