Trying to set up raspberry pi 4b endpoint, and all of the instructions seem to assume that i know things that i don't

Raspberry Pi 4b, I am trying to add an end point to an already working perfectly NUC setup.

What software do I load onto the RPi 4b? How do I load the software?

Roon’s instruction pages cover so many possibilities, and I don’t know which apply to my setup.

Well, what are you trying to achieve. Are you trying to setup the Pi as a digital transport? If so, when outputs are you going to use? USB, SPDIF COAC, TOSLINK?

Most users rely on downloading a pre-done OS, such as DietPi or Ropiee. In those cases, you would download the OS from the OS manufacturer and install it onto a memory card, plug it into the Pi and away you go.

If you are installing linux on the Pi, then you will need to know linux well enough to run the RoonBridge Linux installers as detailed here

If that is what you are stuck on the, you might want to go with one of the others I mentioned earlier

I’m just a fellow user.

I can’t offer anything further than that of @Rugby and @Jim_F

I’ve assisted though by moving this to the Raspberry Pi section of this forum where you might get further assistance.

I would look at RoPieee as a staring point. Works a charm.

1 Like

I thought I’d help further. Here is a link to a thread where the maker of RoPieee posts updates regularly.

@spockfish might reach out to help you should you wish.

1 Like

I’d suggest trying Ropieee as well.
A common stumble I’ve seen here and in other forums is that after downloading Ropieee you don’t just copy it to the SD card as you would with a regular file.
You need to use an app such as

to get Ropieee onto the SD card.

1 Like

I was trying the link you supplied, but the downloaded RoPieee file would not work with Etcher program. Not sure where I went wrong. seems pretty simple and straight forward.

I used this program, but the RoPieee file was said to be not compatible, and the program would not continue.

Are you using a Mac to flash Ropieee to a previously formatted SD card?

And regardless of what OS you’re using I’m wondering if you’re downloading the compressed version of Ropieee and uncompressing it before using Balena? - which I don’t think you should be doing?

Yes it was on a mac and previously formatted. I just switched over to my very old PC and I am about to find out if it works.

Let us know how you’re doing.

I asked about Mac because I once tried to use my Mac to load Ropieee onto an SD Card that I’d previously formatted for Windows and I was getting a compatibility error too.

I eventually discovered that I could just cancel the error message and it would proceed as expected.

The old PC worked perfectly and I am streaming DSD512 to a second hand SMSL SU-9 DAC that I picked up a year ago, and never listened to… until now. Sound great! Thanks to everyone for the help.


You might need to external drive access to etcher on the mac. I use this on my macs all the time and no issues. Anyway you’re up n running now so all good.

Again, thanks for all the help… everything is working great in my wired environment.

But how about wireless? I saw a little direction in the instructions, but trying to access through did not work. I am not sure what to try next. I haven’t looked at the video output of the RoPi since the instructions said the program would disable the video and i don’t have a cable.

I tried to find the RoPi wireless with my phone, but i didn’t see it.

I thought i used th XL version of the software, but i don’t know how to verify that.

Any suggestions as to what to try next?

1 Like

If you type ropieee.local into a web browser can you see it?

yes I did. Thanks!

1 Like

You can enable wireless from the Network tab there.

When i check wireless, and then apply, and then go back, wireless is unchecked again?!

If I remember correctly:
You enable wireless with the toggle.
Go to the wireless tab and enter your wifi info.
Ropieee will tell you something like it needs to reconfigure - click ok.
Then it may tell you it needs to reboot - click ok.

I feel like I am doing the same thing over and over…
I click on the network button and then check the enable wireless. Then click Apply? That sends me back to the beginning…
if i click the network button and click reboot it seems that nothing happens. no matter what i do the Enable Wireless box will not stay checked.
and on configuration method, does it matter which way it is done? I have tried both and neither changes my result.
And on the services… I see them all listed but nothing happens when i click on them.

Are you entering your network details before clicking apply?