Trying to use Roon with Raspberry Pi + ES9028Q2M board (RoPieee)

Hello, I’m semi-new to Roon and brand new to using Raspberry Pi 3 Model B.

I’m a bit of an amateur here but I wanted to try to make my own little media player for a semi-reasonable price and myself a Raspberry Pi and some parts from, most importantly the ES9028Q2M board, which currently has “preliminary support” according to the RoPieee website. I chose RoPieee because it sounded simple enough and I wasn’t gonna use it for much else than music.

Installing and setting everything up seems to have gone well, and Roon on my Macbook Pro seems to have detected the RoonBridge in question…

But when I go to the settings and audio tab, the device (which I named “dack” doesn’t show up.

Am I missing something here? Pretty new to this stuff and I certainly don’t know how to program, so any help is appreciated. I hope I’ve offered all necessary information, otherwise you can just ask and I’ll try to clarify.

Is the RoPieee extension enabled is Roon? Or is the extension only for display? hmm. need @spockfish to chime in…

can you get to the web interface for RoPieee on the Pi? If so, is the DAC board enabled?

No, the RoPieee extension isn’t enabled in Roon, must’ve been something I overlooked.

How do I find and install that? I haven’t figured out how extensions work with Roon yet.

I think the extension just shows up automatically, but only if you are using the 7 inch display on the Pi. I am not sure, that’s why i said we need to get the author of RoPieee to chime in, sorry for the confusion here.

Were you able to get to the RoPieee web interface and go through its configuration? like enabling the DAC?

Yes, I got into the web interface and enabled the Dac, so this is all pretty confusing for me.

I also forgot to mention that I’m currently not using a Display, but I ordered one online so I might install one and see if it gives me any luck when the Display arrives.

The extension is only for the touchscreen display control… Don’t bother with it unless a touchscreen is installed.

Roon Bridge Endpoints should be showing up in the Audio (Ljud) tab. It’s a bit odd, because from the “About” screen, the network address is in the same range as the other devices.

I expect Harry (@spockfish) will ask @Kellie_Ekedahl to send him a feedback file from the RoPieee environment. (Use the web interface of RoPieee and use the “Send Feedback” button on the “Advanced” tab…)

Just a thought, but after choosing the DAC in the RoPieee web interface, you did save the changes and reboot the RPi, didn’t you?

1 Like

The extension is only needed if you have the display connected.

Hi @Kellie_Ekedahl,

Let’s see if we can debug this… Go to the advanced tab on the web page, and hit the ‘feedback’ button. Report the unique identifier back to me and I can have a look what’s going on.


Yes @Kellie_Ekedahl,

It’s important you reboot the device after changing it, so simply press the reboot button that appears when you save your settings.


Thanks, I just left the feedback. And I have tried rebooting the Pi. Doesn’t seem to work.

Do you have the unique identifier of the feedback?

Ok @Kellie_Ekedahl,

Looked at it. There’s an error message when your board is being initialized.

So at least that explains why you don’t see anything (if Roon’s RAAT does not ‘see’ an endpoint it won’t show up in the Roon application).

However, that does not explain why the initialization of your bord is failing unfortunately. I’ve got one lying around, so I can (re)test it to see if something has broken over the last releases.


Here’s the identifier, sorry I forgot to leave it earlier. 3d9a46893aab0ab0

I wonder if I did something wrong when connecting the Dac board to the Pi? I just put it on top of the Pi and made sure all the pins connected properly (I think).

No I think there isn’t much you can do wrong imho.

You could try (although i give it not that much chance) to remove it and put it back again.

Did you use an external poweradapter for the ES9028q2m? Maybe it isn’t getting enough juice?

Hmm, maybe I should look into getting a better power supply. I’m using the Standard Raspberry Pi one, but I’m getting one made for the Allo Kali later on because I’ve invested in a Kali as well. and if that doesn’t work I’ll try a beefier power supply, I guess.

Okay, so I tested doing this with DietPi instead and it worked like a charm. Maybe I’ll stick to DietPi, although I hear RoPieee does native DSD streaming, which is preferable and also doesn’t require a keyboard or anything like that.

Hi @Kellie_Ekedahl,

Still would be great if you would be able to spend some time to test a view things.
If you’re willing to sort this out just let me know.

Regards Harry

I can’t guarantee I’ll be able to be helpful because I’m brand new to this Raspberry Pi thing and Linux in general, but I’d be more than willing to look into it. I’ll get some extra equipment in the mail tomorrow, probably, a new power adapter for the Kali and a touch screen, among other things.

1 Like