Ubuntu 20.04 LTS?

Has anyone tried RoonServer on Ubuntu 20.04 LTS yet?

Thanks.

Just installed 20.04 server on my NUC. A couple of weirdnesses with changes in fstab that I didn’t expect, but up and running enough for Roon Core. I’m very comfortable with shell, but I find a Web based server manager more convenient. Unfortunately, webmin is not working because of its awful security setup, and ajenti doesn’t even install because it’s still based on python2. Oh well, plenty of time this weekend to sort that all, most important thing is that music is working :slight_smile:

1 Like

Have you tried Cockpit?

No, let me check it out, thanks!

1 Like

Installed it today on my headless Ubuntu server, works well and without any configuration hassle. Seems to be a very well done config and monitoring tool. Thank you for pointing this out to us!

1 Like

I’m stuck on Chrome’s unwillingness to accept the default self-signed SSL cert for local Web access. This Core machine is behind a strict firewall and has no public hostname so standard tools to get a signed cert won’t work. Need to do some further research this weekend to find a workaround…

I am on a Mac and my primary browser is Safari. But I have Chrome installed and have tried the access to Cockpit on Chrome. On first access it presents me with a ‘Privacy Error’ screen which shows two buttons: ‘Back to safety’ and ‘Advanced’. By clicking on Advanced I am presented with the option to proceed to the site with unvalid certificate. I’d think on Windows this should be the same…

Thanks, I’m on a Mac too. What you say about “Advanced” is what used to happen when I was using Webmin on Ubuntu 19.10, but now Chrome totally refuses to connect. Need to dig into this more…

What seems to be happening is that Cockpit forces https even when I request http. I added the cockpit.config flag AllowUnencrypted to no avail on Chrome. However, Safari has no problem connecting. Chrome’s security paranoia is laudable in most circumstances, but this is a bit silly. Oh well…

I did a minimal install here, and everything was fine.

20 sudo apt-get install ffmpeg
21 sudo apt-get install curl
22 sudo apt-get install cifs-utils
23 chmod +x roonserver-installer-linuxx64.sh
24 sh ./roonserver-installer-linuxx64.sh

remember to open the firewall!
82 sudo ufw allow from 192.168.1.0/24 to any port 9100:9200 proto tcp
83 sudo ufw allow from 192.168.1.0/24 to any port 9003 proto udp
84 sudo ufw allow from 192.168.1.0/24 to any port 1900 proto udp

5 Likes

I should also mention that I did a restore of the database backup - a very, very important step!

One thing I notice is that on reboot of my server, a couple of my audio devices “disappear”. If I manually power cycle them, they “reappear”. Odd.

1 Like

I see this too. Firewall related, but only discovery.

Are there other ports that need to be open?

This is all I have:

9100:9200/tcp ALLOW 192.168.1.0/24
9003/udp ALLOW 192.168.1.0/24
1900/udp ALLOW 192.168.1.0/24

I’ve not found out why certain endpoints are not discovered after restarting Roon Core. It’s not a big issue because they all reboot automatically in the small hours. But it would be good to get to the bottom of this.

I’ll put in a ticket.

I finally upgraded my headless Ubuntu 18.04 server to 20.04. It went off without a hitch. Roon works fine. I did not notice any issue with endpoints disappearing.

I also have postfix, sshd, smb, and some other utility type daemons running on this server, since it acts as a NAS and a backup server for our home’s laptops and desktops. They all seem fine, although several times during the upgrade I was asked if I wanted to keep my existing config files or replace them with the distro versions. Of course, I chose to keep my existing files.

Anyway – thanks to everyone who responded; I appreciate your time and reassurances.

PS/Edit: I used the simple CLI and all went well.

Because Endpoints have random ports, I did this:
$ sudo ufw allow from [endpoint ip]
The endpoint can now access my Core and I don’t have reboot issues.

2 Likes

Any reason to upgrade from 18.04 other than having something new?

Ubuntu 18.04 is supported until April 2023, so no need to upgrade unless you need newer binaries for other packages.

Roon works fine on 20.04.

2 Likes

I just installed ubuntu 20.04.1 server on a NUC and installed roonserver. I opened the firewall ports. I can see roonserver is running (in top) but no roon device can see the new server. Any hints?