Ubuntu Roon server install tips

Thanks Martin. Ubuntu Server is working great. So, I only ever used this server for Roon, and my library is on a NAS, so I wanted to be truly headless. I suppose I can live with powering down the server with the front button since I have no other access. Is SSH how you would typically do this?

You may prefer to install a web-based GUI. The simplest is Cockpit.

sudo apt update && sudo apt -y install cockpit
sudo systemctl start cockpit.socket
sudo systemctl enable cockpit.socket

Then type https://server-ip:9090 and log in with your credentials.

1 Like

Very cool. Thanks so much for your kind help. I’ll check this out later.

Btw, back on Ubuntu Server, I wanted the most minimal install, so before the installer asked me if I wanted additional software (for DNS, email, samba server,etc), it said only the kernel was installed, and I didn’t install anything else besides cifs, curl, ffpmeg and libasound2, so I’m thinking I have close to what the guys who sell minimal audio linux distros have. Thoughts?

You have a minimal install. However, you said that your endpoint is on another network so this isn’t a big issue.

Hi Martin,

Thank you and Merry Christmas

I have just installed Linux Mint and am a first time Linux user. I installed linux fine on an older i7 Toshiba laptop but using it is another thing…

After spending a long time trying to work out how to install Roon server your info at the top made it easy and I had it done in a minute tops (would be nice if Roon’s own instructions were as easy as yours).

Terminal said that Roon had installed successfully and should be running but I can’t see it running, I can’t find an app for it and my Roon app on phone can’t find any core though I can see the files installed to the opt/Roonserver location on my laptop. In that I can find an .exe file but can’t open it.

Any advice would be greatly appreciated

Thank you

1 Like

Roon on Linux is Core only; there is no GUI so you’ll need to use another Control devices, e.g. iPad, iPhone, Android tablet or Phone, or a MacBook/ PC.

You can check that Roon Server is running by typing the following in the terminal.

sudo systemctl status roonserver

You’ll see something like this.

● roonserver.service - RoonServer
Loaded: loaded (/etc/systemd/system/roonserver.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2019-12-22 11:40:38 GMT; 2 days ago
Main PID: 1638 (start.sh)
Tasks: 128 (limit: 4915)
CGroup: /system.slice/roonserver.service
├─1638 /bin/bash /opt/RoonServer/start.sh
├─1645 /opt/RoonServer/RoonMono/bin/RoonServer --debug --gc=sgen --server RoonServer.exe
├─2120 /opt/RoonServer/RoonMono/bin/RoonAppliance --debug --gc=sgen --server RoonAppliance.exe -watchdogport=36049
├─2134 /opt/RoonServer/Server/processreaper 2120
└─2571 /opt/RoonServer/RoonMono/bin/RAATServer --debug --gc=sgen --server RAATServer.exe

1 Like

Ahh silly me, thank you

You are a guru. I can see with that, that Roon server is active on Linux laptop but neither my phone app or Roon on a Windows tablet is finding any core. I have restarted laptop a few times as has been pretty much standard for me when Roon every updates or changes etc

Thanks again

1 Like

I think Linux Mint comes with a firewall. Can you check and post results?

sudo ufw status

1 Like

You are a genius, thank you so much.

Yep it was a firewall and even worked out how to allow Roon through. A good lesson for me to think about things rather than expect a Windows popup. Linux definitely isn’t as user friendly but it is running a lot better on this older machine that was running Windows 7 that’s soon to be unsupported.

Thanks again mate

1 Like

You can install a GUI front-end for the firewall if you like. it’s call gufw.

1 Like

Thank you. I got to here…It is messy but works. I think I have set rules wrong though. I think it is set to allow both way for Roon but it only works if I set general incoming switch to ‘allow’. If I deny the Roon rule doesn’t work and I lose music playback.

I am guessing this isn’t what I want for a firewall to allow everything in? .

You’ll need the following:

sudo ufw allow from to any port 9100:9200 proto tcp
sudo ufw allow from to any port 9003 proto udp
sudo ufw allow from to any port 1900 proto udp

This assumes your network is

1 Like

You really are the best.
I feel like I am asking too much now. That didn’t work.
Found out how to check my ip and it gave me this
dan@danlinux:~$ curl ifconfig.me

so i edited what you gave me to below with ip of linux laptop

sudo ufw allow from to any port 9100:9200 proto tcp
sudo ufw allow from to any port 9003 proto udp
sudo ufw allow from to any port 1900 proto udp

It then added rules from 29-34 I think but still no luck. I still have to change to ‘allow’ incoming for Roon to work

Lower numbered rules are for Steam app. Nice that it installs from Software Manager and firewall rules are preconfigured.

I wish I could buy you a beer BTW

1 Like

You have an odd IP address range. These aren’t private and I suspect are used by your ISP. For your home network you should be using to range (there are other ranges but this is all you need.)

Edit: TPG Telecom?

1 Like

I thought that too
I don’t remember seeing any other device on my network not having the standard 192 etc

Run ifconfig from the console. 60.242.75 and post the output.162 is your routers address in the Internet.

1 Like

dan@danlinux:~$ ifconfig
enp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
inet6 fe80::298c:17c0:9510:8391 prefixlen 64 scopeid 0x20
ether b8:70:f4:61:d4:08 txqueuelen 1000 (Ethernet)
RX packets 1298526 bytes 1515567209 (1.5 GB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 781203 bytes 556084164 (556.0 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 10721 bytes 855264 (855.2 KB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 10721 bytes 855264 (855.2 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Is this the correct one?