Unable to access HDMI multichannel audio after updating BIOS on ROCK

Roon Core Machine

Intel NUC - NUC10i7FNH1 (apparently the N version no longer supports Audio) running ROCK

Networking Gear & Setup Details

Netgear Gigabit Switch(es)
COX Gigablast Fiber 1GB up/down
All Devices that have Ethernet ports are hardwired

Connected Audio Devices

HDMI to VRRoom or Vertex 2 HD FURY Switch with HDMI eARC to Sonos ARC, Display to Samsung TV qn75q6fna

Number of Tracks in Library

29K Tracks

Description of Issue

Hello, I recently upgraded my core with the plan to use my old core a NUC8i5BE as a Roon Bridge and leverage the HDMI out to play 5.1 FLAC files via Roon and my associated Sonos Hometheater 5.1 setup. This same NUC acting as my core was able to play 5.1 using the same chain. NUC to HD Fury VRRoom switch, sound to Sonos via eARC.

I updated the BIOS to version 90 after running into some install issues with ROCK. After installing ROCK I noticed that the HDMI audio options (3 or 4 HDMI iirc) disappeared in Roon/Audio. Now I only see 1 ALSA driver and it does not have 5.1 or 7.1 channel options as it did before. It’s suspected this was the stereo jack in front and have confirmed that is the case.

I have since tried both Linux and Windows and I was able to get 5.1 to “work”. In Linux the 3/4 HDMI options all show up, in Windows this works a little differently… but it does “work”

However, after experiencing trying to run Roon as an appliance on Windows, I really prefer to run ROCK.

So it seems Intel did something new or different with their latest BIOS BECFL357.86A.0090.2022.0916.1942 that caused ROCK to no longer see the full capabilities of the NUC.

Please help, otherwise, I guess I can try again on Linux.

Hey @Henry_Svendblad,

Thanks for your patience while we work through each thread. Following up on this issue, does the HDMI multichannel function properly if you temporarily run your old ROCK as a core?

I’ll be on standby for your reply :+1:

Thanks for the reply Ben. You can close my issues out. I do think the ROCK should work with the NUC8i5BE on the latest BIOS but it does not. For me I solved making my system a MOCK with Ubuntu server. Everything is working fine and I forced my self to learn LINUX. I learned quite a bit… Happy and using it as an appliance with Chromium as a Roon display.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.