Unable to add network share, unauthorized

Macbook Air 2020
MacOS 12.1 Monterey

Networking Gear & Setup Details

My home NAS/File server is a Mac Mini 2014 connected to 4/4Tb external USB drives (HDD enclosure x4) over USB 3.1
It is connected over Ethernet to my TP-Link Archer AX10 router wi-fi 6, AX1500.
My Macbook Air (RoonServer) is connected also over Ethernet to the same router

Description of Issue

I have followed the procedure described in here: https://help.roonlabs.com/portal/en/kb/articles/faq-how-do-i-create-a-shared-folder-on-mac-and-add-it-as-a-watched-folder-in-roon

And no matter what I do I am unable to connect to my network folder, I KNOW that Roon does not support AFP so I am using SMB. I’ve used a separate windows computer connected over wifi to my LAN and I’ve successfully connected to the shared folder, no problem. I don’t know what’s the problem.

I’ve tried all of this formats and none seems to work

\MyNASDrive\Multimedia\Music or \\Multimedia\Music
smb://MyNASDrive/Multimedia/Music or smb://

Any help will be appreciated thanks

Two remarks.
A) user name with blanks (spaces)? Try without.
B) why not have the mini do the whole job (Roon server)?

I doubt either will work. Best way to know for sure is:

  1. Open up a terminal (in Finder, go to Applications > Utlities and double-click on the Terminal app).
  2. type the command ‘whoami’ (without the quotes) and hit enter.


And make sure to run that command on the mini :wink:

Thanks, this has worked nicely, the original instructions that I’ve shared should point in this direction.

But now I’ve encountered a major issue, Roon has started crashing my Macbook, the whole system. This has started after analyzing my whole library again (with my files on Network folder). This must be a major bug since I’ve not remember an app that has crashed my system like that in years, to the point of needing several hard reboots, ultill I managed to stop it from running at startup. After I’ve done this the system returned to normal, so it is obvious it was Roon the one to blame.

I’ve uninstalled Roon and have not yet installed it again until I backup my system with TimeMachine just to be on the safe side next time I install Roon in case it breaks my machine.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.