Unable to Add Network Share

I have recently completed a Roon Rock build with and Intel NUC7i7DNHE. Everything seemed to be going great until I tried to add Network Shares. No matter what address (path) I enter (and I’ve tried everything conceivable) I keep getting the same message in the pink box: “There was an unexpected error: UnexpectedError”. I am using the latest updated version of Windows 10 64-bit on my PC (Dell XPS 8910 SE), where my backup drives are located (the Network Shares/folders that I am trying to connect to). I’ve seen prior notifications of the need to re-enable SMB 1 on Windows 10, and have done so. I think the problem may have possibly occurred during my attempt to transfer The Roon Core from my Dell XPS (where I had it previously) to the new Roon Rock. I was able to do so, but I’ve got this feeling something happened there with Roon’s network functionality. Everything else is working just fine, except for adding these network locations. Since I couldn’t establish a network share in either the Backup section or the Storage section of the Roon Settings, I had to transfer my music files to the Roon Rock Internal Storage manually (I have an internal Samsung 1Tb Evo 960 SSD for music file storage in the Rock). Fortunately there aren’t too many music files yet; only about 100+ MP3 albums; I haven’t yet embarked on the arduous process of ripping my CDs to FLAC, yet. I tried many paths/addresses, but the one I think it should be (for the backup) is: \\JNKHOMEBUSINESS\H:\RoonDataBackup. Does anybody see anything incorrect with that format/path? I can see the Roon Rock on my Network and on my Router/Gateway just fine and everything else is functional. Could there be a firewall issue? I’m so frustrated that I’m about to reinstall the Roon Rock OS on the NUC and redo the entire Roon installation on everything. If anyone has any advice, it would be greatly appreciated.

  • john

Hey @da_Choge — Thank you for reaching out!

First, so we can get a better idea of your current setup, may I ask that you please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Can you confirm that the proper permissions are enabled on the folder you’re trying to access over the network? Are you able to access it over the network from other machines?

Can you also confirm that you are using the correct username and password when adding the network share in Roon?


1 Like

Yes - there shouldn’t be that “H:” in the middle of the path…I’m assuming that your Roon Data Backup folder is sitting on the H: drive of your Dell? You should have that shared to the network, and then your network path as seen from the ROCK NUC will be:


Or try ipadress and \location as an option.

Normally you should be able to browse if username and pw is correct.

Do you use a specific firewall or anything other that may cause network restrictions. Managed switch ?

Maybe create a “Roon user” on your Network?
I think you haven’t told us where the network shares is. Can that be the issue ?

Very much appreciate the suggestions. Already tried the IP address, but no go. However, I did finally figure it out and I’ll post the solution here, just in case any one else encounters this type of roadblock. I have a Microsoft account (@outlook.com) and the usual usernames that I use for Remote Desktop and other remote logins via the network didn’t work. One that had never worked before (at least as far as I am aware - my first and last name) was accepted just fine - maybe it was just too obvious or something new that was added in one of the more recent Windows 10 Creator updates, but it escaped me until late last night. Even after accepting the Network Share, Roon still couldn’t create a directory, but that was solved fairly quickly by going into the Security properties and enabling allowances for appropriate users (I had already given the shared folder the appropriate sharing properties and opened the proper allowances/authorizations via the Sharing tab, but Roon still wouldn’t create a directory until I allowed certain more buried authorizations in the Security tab. Anywhose, all well and good now. Thank you all very much for taking the time to give me some ideas. Happy Listening !!!

  • john

PS. I’m sure the IP address would’ve worked just as well as my PC’s Network name, now that I know what username Roon was searching for.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.