Unable to add QNAP network share to Roon Core

Brand new setup
ROON ROCK running on NUC8i7BEH, 8GB RAM, 250GB SSD
NAS is QNAP 219P+

Followed installation guide.

  1. Updated bios
  2. Installed ROCK from USB - Version 1.0 (build 219) stable
  3. Installed codecs
  4. ROCK web UI accessible by IP address (all ok)

When I try to add the NAS network share, I get “unexpected error”
Have tried entering both by path (\nas\share) and smb://ip address/share with same result.

I have used SSH to enable SMB3 on NAS
I can access the share from a windows device and sonos without issue.

Any ideas out there?


did you try? Or did you mean IP when you said nas above, i assumed you were using the name


Another issue solved, I had the same issue and your \nas_ip tip worked great, Thanks,

I have tried both the NAS name and the IP address for both

\\NAS name\share
\\NAS IP\Share
smb://NAS IP/Share
smb://NAS Name/Share

Do you also have SMB1 active?

I understand that SMB1 is enabled by default, but I’m not sure how to check if it is running. Here is what I get from smb2status. Appreciate any help.

[~] # smb2status

smbd (samba daemon) Version 4.4.16
smbd (samba daemon) is running.
max protocol SMB 3 enabled.

Usually, there is a min smb config line in the samba config. Like min protocol = SMB2

Although if you are running a NAS, shouldn’t this all be in the nice graphical GUI? I don’t own a qNAP so I am not sure about it. I have readyNAS NASs.

Let me ping @crieke who might know more about the Qnap specifically.

Thanks, Dan. The QNAP 219P+ is an older (close to EOL) machine. Unfortunately, it does not have the configuration settings for smb in the interface. I understand on newer models it is located under control panel \ network and file settings \ Win/Mac/NFS but not on the 219.

I trialed Roon core on an older windows i7 and it worked but performance was not great. That is why i went with the NUC config recommended by Roon.

I have a new western digital NAS still in the box, but wanted to get the Roon core up and running on the NUC before I got into migrating to the new NAS, but got stopped adding the network share.

Maybe @crieke can tell me if the WD PR4100 NAS has any known issues working with Roon before I tear open the box… Also, that is the syntax I used. I also read somewhere that adding .local to the host can help, but no luck there either…

\\NAS name\share
\\NAS IP\Share
smb://NAS IP/Share
smb://NAS Name/Share

Really appreciate the help.

A bit more info… I am able to connect the core on the NUC to a windows share on a PC successfully.

Still not able to access the QNAP. This makes me think the QNAP is rejecting the connection, although I can access it from any of my windows machines and sonos system has no issues accessing the music library on the QNAP either.

@crieke - do you have any thoughts on QNAP config?


It should be doable to enable smb2 or smb3 on that device. I found some info with a google search. But unfortunately it can’t be done in the QTS web ui. So… are you familiar with ssh?

Another thing to check: does your QNAP username or password contain any "special characters”?

Hi Clark, i have the exact same QNaP, used as a backup for my main QNAP.
I have allowed Guest access to all useful shares on the TS-219Plus, and my music files are stored under the default share “Multimedia”;

So, no user creds necessary (And of course, Guests have Read Only permissions).

After adding the Network share, all the subfolders are selectable in Storage dialogue:

1 Like

thanks for the info @Mikael_Ollars,
This still seems odd. I assume guest access uses the same smb version compared to a regular authenticated user login. Can you remember if you had any special characters (like “ä ö ü ø å æ œ ß…”) in your username or password?

Thanks @Mikael_Ollars and @crieke. I did have $ in my password, so I removed it and unfortunately it didn’t help.

Also, I tried Mikael’s suggestion granting read only access to multimedia folder for guests and I am still not able to connect with authenticated user or unauthenticated (no credentials).

Also, as I noted above I did enable smb3 from the command line using ssh, as I found that suggestion a few days ago.

Do I need to restart the NAS after making the permissions changes? That I have not done.

Thanks much.

Break through! Due to the number of failed attempts from this IP, this machine was on the blocked list in the QNAP. I removed the IP from the list and am now able to connect using my designated music RO user! It probably was the special character in the password, so thank you @crieke for pointing that out!!

I find it odd that in today’s complex password world that special characters are a problem, but I can live with it.

Thanks again, @Rugby, @crieke and @Mikael_Ollars for the help. Issue resolved!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.