Unable to Adjust Listening Volume on Cambridge CXN (Version 1) via Airplay

Core Machine (Operating system/System info/Roon build number)

AMD Ryzen 3, 4GB RAM, 450GB SSD C-drive for programs, music library on separate internal 1T HD, Win 10 latest version, Roon 1.6 (build 416) stable 64 bit

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Arris SB6183 modem connecting to Google mesh router, ethernet to 2nd Google mesh router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Cambridge Audio CXN ver 1 connected by ethernet to Google mesh router. TOSLINK optical cable to Marantz DFA-1000 from CXN.

Description Of Issue

Simple (I hope) newbie issue. Library imported fine. Getting the hang of editing and looking at signal path to improve quality, but I am unable to adjust the listening volume using the Roon app on an Android OnePlus 6T phone.

I cannot get the listening volume to adjust on the core computer or the phone using the Roon software. The knobs on the amp work, of course, as does the volume on the keyboard of the computer. Again, I’m not talking about the leveling volume here, I’m asking how to get the listening volume adjustment to work. The sliders will move from 1-100, but the volume never changes. I have “Volume Control” set to “Device Volume” It’s obviously a setting I’ve missed somewhere, but I can’t find which one. Couldn’t find it in the FAQs, either.

Sounds great so far! Thanks in advance.


You might like to post screen shots of your audio device setup screens and perhaps the audio signal path in the now playing screen

Can you control the volume with the wheel on the CXN v1or only on the DFA-1000?


  • If the answer to the above question is yes, then the CXN ignores the volume commands. You have to set Volume Control to DSP Volume in Roon.
  • If the answer to the above question is no, then the CXN’s optional digital volume control is turned off. You can try to enable it and see if it’s working after you made that change. If it’s still not working or enabling the volume control on the CXN is not what you want, then you have to set Volume Control to DSP Volume in Roon.

PS: There is no reason to believe that the digital DSP volume control in Roon is worse than the one integrated in the CXN.

Thanks, BlackJack -

Tried the either/or, and - like many things in life - it isn’t that clear cut.

Volume is controlled only on the amplifier. I tried the CXN “digital pre-amp mode” to both on and off, and neither one made a difference.

In Room I went to the CXN zone, and in Device Setup->Volume Control there are only two choices: Device Volume and Fixed Volume. In other zoned Digital Volume is a choice, but not on the CXN zone.

Interestingly, the remote control for the CXN can control the volume, but I can’t see any setting to disable or override the CXN’s own remote.

I’ll keep plugging-

I’m out of ideas if DSP Volume isn’t an option for your zone.
You might want to provide the screenshots @wizardofoz asked for while waiting for official support to catch up.

Good luck

Hi @robert_vanarsdall,

Can you please provide a screenshot of Device Setup and your Signal Path when there is audio playing to this zone? Device Setup looks like this for reference:

Thanks - Here are the screenshots of the Setup for the Zone in question and the signal path.

As you will see, the Setup I have doesn’t match yours and the pulldown menu doesn’t give me a DSP option. My choices are only “Device Volume” and “Fixed Volume” I’m accessing the Setup through the Home screen =>Settings=>CXN=>Device Setup.

Thanks again for helping on this. It is a relatively small thing in the cosmic order of things, but annoying to not be able to adjust the volume from the best listening zone.

Hi Robert,

It seems you are using AirPlay via the Cambridge as the network player and sending the digital signal to the Marantz.

I assume you are using the Marantz knob to control the volume? Does the Cambridge control volume too?

Does adjusting the volume with the Cambridge remote make any difference?

Cheers, Greg

Right now the Marantz volume knob works. The Cambridge CXN remote volume also works to adjust the volume. What doesn’t work is adjusting the volume using the Roon app. The Android Roon app works quite well selecting material and/or selecting zones. It’s just adjusting the volume that doesn’t work. The slider moves back and forth, but has no effect on the volume.

I’m open to using something other than AirPlay to go from the Library through the CXN to the amplifier if that would work. The CXN is hardwired into the network.

Hi @robert_vanarsdall,

Can you please confirm that your CXN is on the newest firmware? If you have verified this and the behavior is still the same, can I please ask you to reproduce this issue and let me know the exact local time + date you observe it occur at? I would like to enable diagnostics mode for your account in case this provides some more insight into the issue. Thanks!

The CXN is on the most recent firmware. Just checked. Behavior is still the same, i.e. I can use the Roon app (on OnePlus 6T/Android) to change zones, artists, songs, etc, but cannot change the volume from the Roon app.

Roon and the CXN are playing right now. 2:32pm US Eastern Standard time, 6 November 2019.

Thanks - Bob

Hi @robert_vanarsdall,

I have gone ahead and activated diagnostics mode for your account, and what this action does is automatically upload a set of logs to our servers for analysis.

I can confirm that the report was received, but I did not notice your attempting to change the volume at the specified timestamp.

Can I please ask you to reproduce the behavior by trying to change the volume for a bit of time (30s - 1min) and let me know the exact local time you try to do this at?

Thanks, Noris -

It is 7:50pm EST (US). I’ve just attempted to change the volume and will continue on and off for the next 5 minutes.


Repeatedly tried (unsuccessfully) to change the volume using the Roon app on OnePlus6T/Android from 7:50pm to 7:55pm.


Hi @robert_vanarsdall,

Thank you for letting me know those new timestamps. I can confirm that diagnostics have been received and I have requested the technical team to take a look at these traces. I will be sure to let you know once I have more info to share.

Hi @robert_vanarsdall,

I spoke to our technical team regarding the diagnostics gathered from your machine. The Cambridge CXN v1 does not appear to be accepting any volume changes via airplay in Roon. We suspect that this is a device limitation, but to further confirm, can I please ask that you try using iTunes to stream some audio to it and then try changing the volume via iTunes? Does that fail as well?

Well, damn!

Turned Roon off, streamed from iTunes to the CXN, and iTunes can’t adjust the volume at the computer or on iTunes Remote! I used to be able to do it with the Apple AirPort Express and just assumed it was built into everything.

I’ll take this up with Cambridge Audio. Big limitation to have multi-room design and not to be able to adjust volume.

Thanks for the diagnostic help. Glad it isn’t Room’s problem.

1 Like

Hi @robert_vanarsdall,

Thanks for confirming this issue occurs in iTunes as well.

Yes, reaching out to Cambridge Audio with this report would be the next step :+1:

Just a follow-up on this to close the loop, should anyone else experience something like this.

Cambridge Audio’s CXNs admirable digital processors only work on the units’ analogue outputs. In trying to get as clean a signal as possible, I had digital in and out, and had tried both TOSLINK optical and coax inputs and outputs. Hidden away in the CXN manual was a single pretty ambiguous phrase telling a user that the CXN’s volume controls only work with analogue output.

Roon sounds great, and volume control works!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.