Unable to connect Roon ARC outside my home network

I am still unable to connect Roon ARC from outside my network.

I have confirmed that I can access my Disk Station (NAS) from outside of my home network. I am able to listen to music and watch movies that are on my NAS when away from home. I am not a genius when it comes to computer networking, but the fact that I can access my NAS from outside my network but not Roon ARC leads me to believe that Roon ARC isn’t configured correctly.

Below is the diagnostic.

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“172.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n501\nPAL_UPNP_SOAP_E_ACTION_FAILED\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>\n”}

Hi Scott,

The diagnostics you’ve provided suggest that UPnP is not properly configured on your router. If you could try the steps below and provide the information requested, that will help when Roon support staff engage aft er the weekend.



Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?
1 Like

UPnP/ is enabled.

The modem is not in bridge mode. It is in automatic configuration DHCP

The firewall is off and there are no VPN’s

I unfortunately don’t know how to check to make sure the IP/Port matches the port listed in ARC

I don’t know how to manually open the port in my router’s port forwarding configuration

My modem is a T-Mobile hotspot

I have a Linksys Smart WiFi

I have no additional network hardware other than the three nodes that make up my smart wifi.

T-Mobile is my service provider and I live in VA.

1 Like

Hi @Scott_Savold,

Unfortunately, T-Mobile 5G is one of the few ISPs known to interfere with ARCs out-of-the-box configuration due to their specific implementation of IPv6 and carrier-grade network address translation.

The Roon team is making progress on solutions that will enable port forwarding to function for T-Mobile hotspot users either via autoconfiguration (UPnP) or manual port assignment. We’ll be reporting progress in the main T-Mobile thread here: T-Mobile (US) 5G Home Internet: CG-NAT Blocks ARC, Workarounds Required [Ticket In]

Until then, I recommend exploring some of the more simple VPN solutions our users have accumulated, like this one: Roon Arc + Tailscale with T-Mobile Home Internet. Here’s another: Success with Tailscale VPN

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.