Unable to connect to an SMB Share on a Mac OS Big Sur iMac

Core Machine (Operating system/System info/Roon build number)

Macbook Pro - Mac OS Big Sur
Roon version 1.7 build 667

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Not applicable for issue.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Not applicable for issue.

Description Of Issue

I have tried for hours to connect a share on a second Mac OS computer (iMac). On this computer a bunch of high-res audio files are stored. Roon is installed on a Macbook Pro with Big Sur on it. I setup SMB sharing. Connecting to this share in finder works just fine. Connecting using Roon simply does not work. I get “Authentication error” all the time. Whatever I do. I should mention the connecting to this share on a command line using “mount -t smbfs…” also does not work.

I am not your average computer user, but this is just too complex and cumbersome.

Just use the IP address of the iMac and \musicfoldername.

I tried that also. Did not work.

@support …this will help

how are you entering the address of the folder you are trying to connect to in Roon? I remember having to make a shared folder on the Mac with the music on it, then turn on file sharing and then go to “options” and turn on SMB sharing and selecting my Mac sign on name. and then instead of using the IP address, I entered “smb://Animals-iMac.local/Shared Folder” . You would just replace “Animals-iMac” with whatever the “computer name” is in the sharing preferences window. You will also enter your Mac user name and password you use to unlock the computer.

Hi @Berry_Groenendijk,

Can you share a screenshot of the share settings for the folder in macOS? Can you also share a screenshot of what you’re entering into Roon?


Have you tried the following?
\\[IP address]\[Drive name]\[Folder name]

Thank you for trying to help me.

This is a screenshot of the share settings:

SMB sharing is on. AFP is set to off.
I have restarted sharing. Restarting machines.

But what ever I enter in ROON I still get authentication errors. So, I have tried:
I have also tried backslashes instead of forward slashes.

I can get to my second Mac just fine using Finder.

I have carefully checked my login name and the password I enter. I have even used variations on my login name. I have tried substituting spaces by a dot. Nothing seems to work.

I guess it probably has nothing to do with ROON.

Jesus, man - be careful!
Not everyone needs to know your accounts …
And by the way - do not share using the admin account, create a special account for sharing - cannot be ruled out that Roon Lab might know password entered into the Roon program…

1 Like

Try clicking the Options/Opties button and check that

  1. SMB sharing is enabled, and
  2. Windows file sharing is enabled for the account you use for connecting in Roon

I took your advice. I created a new account and used that for sharing. Used a login name without spaces. And it worked. Thanks! As always the solution is quite simple :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.