Unable to connect to network share after moving music collection to new NAS [SOLVED]

I have named the NAS the same as the old one. Roon core is running on a dedicated windows 10 machine. I have reconnected this machine to the new NAS and it can browse the files without any problems from windows explorer.

The same is true for the machine(s) running the full Roon to control this core, they all can browse the NAS just fine.

When i try to connect Roon to the share i get a NotAvailable message and no files:

Any idea what i can do about it, because i tried all what is mentioned elsewhere on the forum?

Have you just left the original config in place and named the new NAS the same as the old hoping it would work? If so delete the NAS from the Roon config and add the shared folder again as if starting from scratch.


Yes i did that too… removing everything i could find within roon poitning to the (old) NAS and created the share again with the result shown in the picture…

The user and password used can connect without issue to the share from within windows explorer…

Can you remove the NAS entry again and try adding it by IP address? Just want to exclude a DNS caching issue in this scenario. :slight_smile:

Thank you guys for the quick replies! :slight_smile:

I already tried IP address only, it gives the same issue…

I had some similar problems. The root cause was the SMB setting in my NAS. Depending on your model try to use the SMB2 or SMB3 option and mount the share after cleaning the SMB cache…

Just my 2c

Well, i did clean the credentials from the credential manager. It’s a QNap TS-659 Pro II NAS. There are not much settings concerning SMB, the NAS is configured as stand alone server.

Now i am even a step further away from home and not able to add the share even:

And i am REALLY sure the settings are correct, as said, windows can connect without issue with the provided credentials…

Are you sure about the workgroup entry? In most setups this entry is not needed and should be left blank.

Also: Just wanted to confirm, if your share is really called “share” (or is it maybe Music or Multimedia…)?

@crieke, you are great! :slight_smile: That was the trick indeed, the share wasn’t ‘share’ (although it was in the old situation, what causes the confusion because the folder structure is the same) but multimedia indeed!

Thanks again!

Great, that it works now.
I just spotted “share” as it is quite an uncommon name for a share, especially on QNAP when there are some share names already configured by default. So, just a lucky guess…

Well, before (the old NAS was running for 7 years or so without reinstalling) “share” was the root of the other share, you could just map to it and see all other shares. It looks like they have changed that along the way. Because i configured the ‘new’ NAS from scratch this ‘new’ setting propably went active without me knowing and trying desperately doing the same as before…

Thanks again!