Unable to connect to Nucleus

I have the exact same issue (but I’m using a Nucleus, not a “+”). Restarted and rebooted everything, the problem persists. I must say, I’m scared to reset the “Database and Settings” although I have a backup…does that mean I have to install my latest backup afterwards???

HI @MatDe,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Can you share a screenshot of what you’re seeing when you try to connect to your Nucleus?

Hi Mat,

I took the risk and did a complete reset of the database and that was the solution. What your nucleus will then do is rescan your database to reconstruct your library. Takes a bit of time but not too painful. Hope this helps and good luck!


I’m using a Roon Nucleus with internal storage (all my files are on an internal SSD). The Nucleus is directly connected to my router. I’m using either my Mac or an iPad to access the Nucleus. At the moment there is no audio device connected, I usually stream via Airplay to one of the devices mentioned above or to a Pioneer XS-S30DAB,. I’m doing this for months now and everything worked fine…until yesterday.
I opened the Roon remote and was asked for my username/password (what never happened before). Login was not possible, all I see is the “Logging-in-logo” that just stays there.

The WebGUI shows that everything is okay and I can connect from my Mac Finder to access the Nucleus…looks as if everything is okay there.
The Nucleus is connected to my Qobuz-account and there are about 1000 ripped CDs on my internal SSD…so there’s plenty of space left.

Thanks for your help!

Thank you! So there is no need to use my backup files??


No you shouldn’t. I didn’t have a backup. So long as your NAS internal drive is connected to the router, the reset of Room database should mean it will simply have to rescan your NAS to construct the library again.

If you want to preserve history, metadata edits and what not, a backup restore is required.

Well, I would like to keep as much as possible! But I’m not sure what steps I have to take and in what order. I’ve been searching for this but couldn’t find any tutorial.

Before you do any more, make a backup to preserve all the curating you may have done on your system.

From Settings==>Backups, set up your backup location and a schedule -

Once you have set up a location, etc., you don’t have to wait for a scheduled backup, you can force a backup -

Even if the backup says that it completed successfully, double check by selecting ‘Clean/Restore’ from the same menu.

You should get a screen that shows your latest backups -

Now, you can safely reset your database.

When that’s all done go to Settings==>Backups==>Find Backups and select the folder that you backed up to (it’ll end in Roonbackups) -

You’ll get a screen like this -

Select the backup you want and restore.


@xxx Thank you so much for this detailed tutorial! Highly appreciated!!!
I already made some backups in the past and stored them on my Synology NAS. Since I can’t log into Roon at the moment it is not possible for me to make a new backup. But there is this “Restore a backup” on the login screen and I can access this. This looks pretty much like the pic you shared:

but when I click on the folder I see this:

No backups to select…am I missing something???


Not sure what you mean by this.

Don’t click on a folder, click the button that says ‘Choose this Folder’.

Why not?

Are you saying you have already done the Reset or are you saying that you are using the latest release that seems to be causing some problems on Nucleus machines?.

If the latter, I would advise waiting until that’s cleared up and then trying to do a Restore.

If you still have the same results, you can always force a new backup, check that the backup is good, reset your database and then try another Restore.

Ah! “Choose this Folder”…sorry, found it! And now I see my backups!

I haven’t done a reset, yet.

I am using the latest release, everything worked fine for me…just 2 days ago all of a sudden the login showed up (never did before) and I found out that I can’t login.

So if I get his right:

  1. I should reset the database&settings via the WebGUI
  2. Restore from my backup

Is this the way? Sorry for the inconvinience.


No problem.

If it were me, I would -

  1. Force a fresh Backup. That way you have the latest and greatest version of your Roon library.
  2. Do the Reset
  3. Restore what you just backed up.

OTOH, I’m not convinced that you weren’t led down a primrose path with this post -

I’m not sure you need to do a Reset, although if you follow the steps I laid out, it won’t hurt.

I an retagging @support. Let’s see what they think.

Good luck.

Edit: Oh OK, you can’t do a fresh Backup because you can’t get on the Nucleus. I get it now, sorry.

No problem. I agree, let’s see what support thinks about it.
Anyway, I feel a lot better, now that I really understand the whole backup thing.

And besides that: I can add the phrase “you were led down a primrose path” to my vocabulary. :wink:
That was new to me (I’m German).

1 Like

:sunglasses:, See meaning #2 -

haha, very confusing…

I‘m still waiting for support to help me…

Hello @MatDe, my apologies for the delay here. I spoke to the team about the best course of action to get things sorted out for you. If you could please try to access your Nucleus one more time and reply to this thread with a timestamp when you do, I’d like to enable diagnostics for your account and take a closer look with the team. Thanks again for your patience.

Hello @nuwriy,

I tried to log into my Nucleus at 09:27 a.m. CEST.


Hello @MatDe, thanks for the timestamp! I took a look at the diagnostic and we didn’t see anything that specifically pointed to an issue with the Nucleus’ operation. So we can gather more information, can you try to connect with multiple remotes next time you’re in that state? I’d like to see if the issue is reproducible with any remote you use or just the Mac, thanks!

Hello @nuwriy, thanks for check. I‘ve tried multiple remotes: iPads, iPhone and Macs. The result is always the same: I can‘t login. I restarted all of these devices as well as the Nucleus and my router.
But my main problem is still unsolved: what is the best way to get out of this? My Nucleus is at the moment unusable.
Shall I reset the database? Use my latest backup? What is best way to get access again?