Unable to connect to Roon Core on Synology NAS after update to RoonServer 2.0 (build 1143)

Roon Core Machine

  • Audio library and backups stored on Synology DS918+ (DSM 7.1.1-42962 Update 2)
  • Roon Core manually installed on an externally connected SSD using RoonServer_Synology_DSM7_x86-64_20220216

Networking Gear & Setup Details

Synology DS918+ connected to Asus AS6000 router using Cat6E Ethernet cable

Description of Issue

My setup was working relatively smoothly (with ARC too) till last week when I was prompted to update to RoonServer 2.0 (build 1143) production. After updating, I’ve had constant issues connecting to RoonCore from Roon Remote (both from Windows and Android).

After manually running the Roon Server package in Synology Assistant (it’s on an external SSD, so it doesn’t start automatically), I can sometimes start the connection to my Roon Server but during the connection phase, I get timed out with the ‘uh-oh…’ message. Stranger too, I sometimes see Roon Servers that do not belong to me in the list of servers that I can connect to.

Most of the time, I’m stuck at the ‘Looking for your Roon Core’ message in ‘Choose your Roon Core’, and need to force-shut down my Synology.

I’ve tried formatting my external SSD, reinstalling RoonServer multiple times and I’m still unable to successfully connect to my Roon Core.

There are no hardware issues with my external SSD nor my Synology DS918+.

My initial thoughts are that USB power management is disconnecting or sleeping the external SSD and quitting Roon.

Why are you running Roon Server on an external SSD rather than on an internal volume?

There are some slight performance improvements from running Roon Server on an external SSD rather than on an internal volume on the NAS.

This setup was running OK till I installed the latest Roon updates pushed out last week. And as mentioned in my original post, thereafter I wasn’t able to connect to my Roon Server and at times I could see (and connect to) Roon Servers belonging to other people on my network. I don’t know how this is possible as I’m the only one running Roon on my network.

I’ll reinstall Roon Server on the internal volume on my NAS if this can’t be resolved.

Going with this piece of information, it sounds more likely related to your network configuration than it has anything to to with the drive Roon is installed on.

Hey @AC108,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

Following up on this thread, are you still experiencing issues connecting to your core? If so, please take note of the date and time the next time this issue happens, and share it here.


Hi @benjamin, I tried it a few more times with the same results, so I disconnected the external SSD from my Synology DS918+ and reinstalled core on my internal volume. Not ideal, but I have no issues connecting to core now. I’ll try installing and running core again on the external SSD when the issues with this release settle down. Thanks.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.