Unable to connect to Roon Core Server (Linux) from different subnet [Answered]

Hi – Installed Roon Core x64 on Ubuntu 17.04 last night on my home LAN; current versions of everything. My Roon remotes work great when located on the same LAN. However, I can’t get the Roon remote to connect from any network outside my LAN, on a different subnet, connected through an “allow all” VPN.

Home LAN1:
Remote LAN2:

I’m able to ping the Roon Core server from the remote LAN, and ports 9100/9101 appear open when I run nmap. No ports are blocked. I’ve tried several clients from LAN2 – none can connect to the server, even when I specify the IP and Host and click “scan.”

I also tried port forwarding UDP 9003, TCP 9100-9200 on the LAN1 router and connecting from both LAN2 and through my cell phone’s network to the public IP. Also can’t connect. When I view the logs on the server, a connection attempt doesn’t register.

What gives? Is it possible to access Roon Core server from a different subnet? Any suggestions? Everything works great when I’m on the same network.


Roon is built to only work on the same subnet.

Wow; ok. I didn’t know that. I was so excited to use Roon as a Plex replacement for my music. Thanks anyway.

@Adam_Goldberg I think @danny (Dulai) once said that you can input the IP of the Roon Core in the search box or dialogue when you are on the ‘other’ subnet. Provided you have routing set up between subnets of course. I do not know if it is possible to have Core play to a RAAT device across subnets, but it should be possible for a remote to find your Core this way


This might help you:

This topic was automatically closed after 3 days. New replies are no longer allowed.