Unable to connect to Roon from Remote or ARC after Windows update

Same problem here after the recent update on my windows server. I added the missing RoonServer to the firewall exclude list and it did not help so something more fundamental broken with this update.
I have also lost my squeezebox connection with this latest update.

Lets hope the problem gets sorted soon!

1 Like

There was a windows update today as well so maybe windows have changed something to prevent these connections??

“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“86.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}


Maybe it’s just your router being confused by the update and it still has a port forwarding rule in memory for the previous version of the Roon server. Try rebooting it.

Or maybe the old Roon Server is somehow still running, so reboot Windows too, on the server machine.

OK I have found a fix for this Roon iPhone issue and the Roon Arc issue and the Squeezebox connection issues after this new Roon upgrade.
RoonAppliance.exe and RoonServer.exe need to be added as exceptions in Windows Firewall.

You can find the location of both these services by doing a Control + Alt + Delete and selecting Task Manager.
Under the Processes Tab you can scroll down and to find both these services.

Leave Task Manager open for now and go to the search bar at the bottom left of the windows taskbar and type in the following:
Control Panel - then click on Windows Defender Firewall - then click on Allow an app or feature through Windows Defender Firewall

Now in the list of allowed features you should have the following 4 items listed:

If you are missing any of these 4 items then you need to add them by the following method:
Click Change Settings
Then click Allow another app

Now here is where you use the Task Manager window opened earlier
Scroll down the process list until you find one of the missing items and right click on it and click Properties
Here you will see the location of the service and you need this location string for the Firewall list.

Go back to the Add an APP window for the firewall and click Browse.
Now browse to the location of the service you want to add and select it and OK it.
Do this for any other of the four you are missing and add them to the exclusion list.

After doing this you should see all 4 items now listed in the exclusion list.
I selected both Private and Public check boxes…not sure if both are required but they work for me and someone here with better knowledge can let us know if both need to be selected.

Hope this works for others here, I had tried all the router port forwarding tips others had used but I had no luck with any of the other solutions.


Now that you mentioned it, I seem to recall that you are not the first to mention RoonAppliance needs to be added. If this is so, someone should update the FAQ

1 Like

After many tries and much frustration I found that Roon server was not added to the firewall exceptions, and I added it. I rebooted the streamer/server and the router. No improvement. Still no use of iPad controller or Roon Arc. It seems to find the server but is unable to connect. I also rebooted the Hegel amp. I still have no solution available. Roon really needs to provide technical support to fix these issues promptly.