Unable to connect to Roon OS

Roon Core Machine

Dell Optiplex 3070, running latest version Win 10 PRO, with all updates, i5-9500T, 8 GB RAM.
Connected to a switch by cable.

Networking Gear & Setup Details

Connected Audio Devices

  • PC that’s running Roon Client, connected to the same switch by cable
  • Bluesound Node 2i, , connected to the same switch by cable

Number of Tracks in Library

Something like 10000 tracks.

Description of Issue

hello, I just made a clean install on win10PRO on a PC (Trial version!!)

I installed the server software and the client software on the same PC.

On the Client software, I can see my NAS, my clients, and I can play music to the Bluesound, and to a PC that is running the Client software.

But the client software on another PC cannot find the RoonOS, neither my iPhone.

When I check on the server, then I have the setting as below, but the ‘enable connections’ tab is missing.

If I select ‘Find Roon OS’ there (on the same PC as where the server is running), I also get a message that he cannot find the Roon OS

The Windows is a clean install, I already uninstalled the RoonOS, and reinstalled it, but it stills the same

What am I doing wrong?

Best Regards

You won’t find any RoonOS devices as your not running ROCK or a Nucleus. RoonOS is the operating system that Roon uses for the Nucleus or DiY servers called RoCK. Its not endpoints you have nothing to worry about.

hey, thanks for the reply!

Does that means that I need to install Rock on that PC?
Or is it impossible to run a ‘server’ on a PC?


You can run Roon server on windows,.Mac, NAS, or Linux. RoonOS is designed to be installed and run just Roon and nothing else. The images they supply are created to run on Intel NuCs and is only fully supported on certain Nuc models as this is what the Nucleus is based on. However many install it on other pc systems and it works fine, mine is not a NuC and is fine If it’s a modern intel motherboard as long as it supports legacy boot it’s more than likely to work but your on your own if not using supported hardware. You don’t need this unless you want to solely use the computer to run Roon and are not bothered about loosing what’s currently on it, as it will fully erase everything. Just install the Roon server app for Windows or Mac and your away.

As mentioned, that setting is not used with your setup. Windows runs Roon or RoonServer just fine.

Does that means, that it’s only possible to control the audio devices only from the Roon Client that is running on the same PC as the Roon Server? Is that the limitaion of that setup?
No possibilitie to control from ‘mobile’ devices or laptops or what it may be?


You can use Roon on mobile, tablet or laptop to control as long as they are on the same network as the Roon core server, what ever os you decide to use for the core. The core does all the work, whilst you use just a remote to interface with the core and play music to your devices.

“Our control infrastructure is designed carefully to work identically whether you are sitting in front of a computer running a Roon core , or whether you are using another device on your network. It works just as well if you have one control or a dozen. Data on different controls stay synchronized in real-time. There’s no lag, and we never let you see stale data. These details may seem abstract from where you’re sitting, but these ground-up architecture choices act together to produce an unparalleled multi-device experience.”

From roon help.

thank all for the reply!
But why m I unable to find my Rooncore on the network, in that case?

firewall is disabled on both, Server and PC are connected on the same switch both with a IP address like 192.168.0.xxx

Also when I enter the IP of the server, the client is unable to connect

Have you tried the troubleshooting steps from:

yes I did!

but only the first line ’ Accept Remote Connections’, I cannot find on my setup
I guess it needs t be done, but Gypsy and Rugby said that this is not needed.

Is there a way to access a webpage or a UI from the server?

If it’s not there, then it is not needed in your setup.

If a remote can’t connect, then usually something is blocking the connection (not on the same network, firewall, antivirus software). Follow the troubleshooting steps (disable all firewalls, antivirus software on core and remote; disable VPN if you have; make sure machines are on the same network WiFi or wired may matter here).

If you need more help, you may have to provide more details. You didn’t even share real details about the non-working remotes. From the document linked above:

Additional Troubleshooting

If you’ve confirmed everything above, and you’ve already restarted both computers, please let us know the following information below:

On your main Roon install:

  1. Operating System

  2. Firewall status (type, whether enabled)

  3. Network connection (WiFi/ethernet, IP address)

On your remote Roon install:

  1. Operating System

  2. Firewall status (type, whether enabled)

  3. Network connection (WiFi/ethernet, IP address)

Network configuration:

  1. Network hardware (routers, bridges, switches, media streaming devices, network security hardware, etc)

No, it does not.

If you are running RoonServer on Windows, MacOS, or Linux, that option is useless and does nothing. The option only does something if your RoonServer is running on RoonOS, aka Rock or Nucleus.

RoonServer on Windows, MacOS, or Linux does not have WebUI. Only devices running RoonOS do, because RoonOS does not allow the user to directly do anything on the machine it is installed on.

As Blackjack said, there is something else going on. Could be firewall on the server or client, it could be that the server or client has their network set to public instead of private, it could be that the server and client are on different network subnets (Roon does not cross subnets).

Make sure it is on the same subnet, some networks have Wifi and wired on different ones. If so, then when you cannot connect click the blue help button and when given the option to put in the server IP use instead.

1 Like

just an update, problem solved, run’s like a …

I reinstalled the PC with an image from Dell, installed all the Windows updates, and installed Roon, and everything works now.

The Windows image that was before on that PC, was a (clean) image, but pushed through the IT department where I work.

And I guess that there are some hidden security settings somewhere.

The most important, I can start to evaluate Roon now, untill now it looks great

Thanks all for the help!
Case closed!!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.