Unable to connect to Roon with iPad Pro

Hi folks - I am have spent countless hours trying to resolve a connectivity issue with no resolve - hopefully someone can help. In a nutshell, my iPad Pro can not connect to the ROON library, resident on my NUC. NUC is connected with a LAN cable. Wireless router used for the iPad (Netgear WNDR 4500). The network chain is:

  1. Cable Modem;
  2. Netgear WNDR 4500 wireless router;
  3. Netgear FVS-318G switch with a port sent to two locations;
  4. a Netgear GS-108 switch where the NUC and server are connected;
  5. a Netgear GS-105E switch where the NAS is located.

Roon is set to allow remote connections. Firewalls have been deactivated and the ROON app has been set to active in the incoming firewall rules. I have a detailed diagram but can’t figure out how to post it here. The iPad shows that it is trying to connect to the library, but it just keeps failing. I’ve tried manually entering the IP address - no luck. I see the app starts to connect, the immediately fails. Any way to reset the library path? It doesn’t allow we to do so when I click “I want to connect to a different library.” .

Not that I want to use WiFi on the NUC, but interestingly, if I enable WiFi on the NUC, it can find the library - but not via the LAN. Also interesting that the server audio zone disappears when WiFi on the NUC is enabled, so that does no good. I’m at a complete loss. How do I post a diagram of my network connections on the forum and I’m hoping someone with excellent networking skills has a remedy.

Thanks in advance.

Export the network diagram as a .jpg and post it in this thread using the upload icon (7th from the left or Ctrl-G shortcut). What you’re describing though sounds very much like a firewall issue.

Thanks audiomuze. It does seem to be a firewall issue, but I did enable Roon on the NUC server as an allowed incoming app and I tried defeating the firewall (though I would like protection from external access). I thought perhaps it was a security setting with the wireless router or the switch, but I can’t find anything suggesting that is the cause.

Attached is an outline of the network configuration and related issue.

Looking at the diagram and your connection issues I’d say the problem has to be with the WNDR4500 config allowing the iPad to access the internet but not communicate with the rest of your LAN. I presume the WNDR4500 is doing duty as DHCP server … are all WiFi devices assigned on the same subnet as the wired side of your network? Can the iPad see anything else on your network?

Hi audiomuse.

I just now figured it out, after endless trials. I think you were on the right path. The FVS-318G is itself a DHCP router/firewall, so I had conflicting DHCP routers and the 4500 reverted to a 10.0.0.x schema while the FVS followed a 192.168.1.x schema. I rearranged the flow:

  1. Cable modem
  2. FVS-318G feeding all the following:
    3A) WNDR 4500 wireless router/gateway
    3B) WNR100 wireless AP (wireless portion of alarm)
    3C) GS-108 switch
    3D) GS-105E switch

Certainly learned a lot about networks…

Thanks for following up and providing insight.


Glad you got it sorted. Nothing more frustrating than wanting to listen to tunes and not being able to.

Oh, and the key was to reconfigure the the WNDR4500 as a simple Access Point vs. a router.

The key issue was having multiple DHCP servers on the network. Multiple routers are usually fine if properly configured.