Unable to connect to Squeezebox [Solved]

I started a trial period but after setup, I am unable to get Roon to see my Squeezebox devices.

I setup Roon on my HP Spectre360x laptop running Windows 10. My music is on a ReadyNAS Duo Ultra 2. I turned off LMS on the NAS and powered down the NAS, and 2 Squeezebox touches - then powered them back on, but I do not see them in the Audio setup tab. The only playback option I have is the laptop that is running Roon.

There is no username/pw to accress the NAS, and when I look at the storage tab it states that it is connected and watching folders in realtime.

Any suggestions to solve this?

I don’t use Squeezebox but…

Under Settings > Setup did you select Enable Squeezebox support?

Cheers, Greg

Sorry, I left that bit out, but yes I did go into settings and enabled Squeezebox.

Did you follow the instructions in the FAQ?


Yes, I followed all the steps in the setup instructions detailed here: https://kb.roonlabs.com/Squeezebox_Setup

Did you get a prompt to allow Roon through your firewall?

There’s no chance LMS is still running on the NAS or on another PC?

I’m presuming there is no “Squeezebox” to enable in the Settings > Audio tab?

Do you have any airplay devices in the house that you can check can Roon get to them?

What version of LMS are you running?

The answer may lie somewhere in the above.


  1. No, I did not get any prompt to allow Roon through my firewall
  2. Absolutely no chance - LMS was only running on my NAS, I’ve never installed it anywhere else
  3. In the Settings>Setup there is a switch to enable Squeezebox support and that has been enabled, but there is nothing on the audio tab
  4. I don’t have any Airplay devices
  5. I am running LMS 7.8


Try turning off the firewall to rule that out.

Rather than LMS I meant do you have the latest Squeezebox firmware version?

And just to rule out network, if you turn on LMS again does it work?

It really does generally just work.


Ok, I turned the firewall and turned back on LMS just to make sure the network was fine and everything ran perfectly.

I then turned off LMS again, rebooted server and endpoints and tried again, but still no success.

Firewall is off, and the firmware on the Touches is the latest (7.8.0-r16754).

I’m sure it just works for most, but in my search for a solution there seem to be many others with the same problem, without resolution. I’m just glad there’s a trial period.

Unfortunately it’s probably bad timing looking for support when a major version has just been released. Hopefully one of the mods @andybob or devs @mike can help.


Hi Ben,

I don’t know enough about Squeezebox to help. @mike and @vova will be able to look into it and advise.

Factory reset your Squeezeboxes. If you do a search you’ll find that this generally cures Roon discovery problems on the network.

I was in the exact same situation. A factory reset of my Touch was everything I needed to get connected.

Thanks for all the replies, I had to do a bunch of things that I will list here in case others have the same problem and are trying to troubleshoot.

To recap in the order in which I tried to fix my inability to connect to my Squeezebox Touch:

I ran through this setup provided (https://community.roonlabs.com/t/how-do-i-use-roon-and-squeezebox-devices-together/5865/2)

LMS is on a NetGear ReadyNAS Ultra2 and I went into Raidr and turned it off.

I installed Roon on my Windows 10 laptop

Squeezebox Touch firmware is up to date (7.8.0), and I reset the unit to factory settings (in the advanced settings)

I discovered my WiFi network was set to “public” and I set it to “private”

Firewall has been disabled (but did not need to be in the end)

Shutdown and reboot laptop and Squeezebox Touch

I then had to manually the IP of my laptop manually into the Squeezebox Touch Settings>Advanced>Network>remote Libraries>Add New Library

Only then did the Squeezebox Touch show up as an option in the Audio settings in Roon

Thanks all for your help and suggestions!

Glad it worked out positively in the end, now enjoy the great Roon experience.


I have a strange problem similar to the above described issue . I use intel nuc as roon server, and I have 2 squeezeboxes (sb), a sonos speaker pair and Marantz 8802. Roon sees all of them. However, today, I powered down the nuc to place it to a different location and when I switched the system on again, one of the sb s disappeared. Strangely a roon logo was displayed on sb display? I switched the sb on/ off few times, still the same problem. Does anybody have a similar issue?