Unable to delete Tidal albums

Roon Nucleus+ ; Roon Version 1.7 (build 505) on Nucleus+ and iPad.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Nighthawk router; Nucleus+ is connected by ethernet. iPad accesses Roon via wifi.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Seagate HD connected to Nucleus+ via USB

Description Of Issue

About 3 dozen singles showed up on Roon with Tidal labels. I could not delete them from the Roon program. I deleted all the singles from my favorites collection on Tidal itself. (I did not save the songs to begin with and do not know how they showed up on my account.)
I closed and reopened Roon on my iPad. The deleted song covers still showed up. I cannot delete them—error message shows ‘file not found.’ If I try to hide them, nothing happens. Yet even though the file cannot be found, it will play if the play icon is tapped.
I turned off the Roon Nucleus+ and rebooted it a few minutes later. Songs still show up on Roon (but not on the Tidal site); I’m again unable to delete them as files could not be found.
I disconnected my Tidal subscription on Roon. I re-entered the subscription info and the album covers still showed up (even though they are no longer in my Tidal account). I against tried to delete them but got the same error message telling me the files cannot be found or I do not have access to them on my hard drive. (They were not downloaded files.)
How do I get rid of these?

+1! I have the exact same problem. When I try to delete a TIDAL album, I get the error: File not found/No Access to Hard Drive!

Hi @Michael_Cohen / @Florian_Loffler1,

I just tried deleting a TIDAL album on my end and it is working as expected.

Could you please share a screenshot of the affected albums on your end?

Is there any change in behavior if you go to Roon Settings -> Services -> Edit button next to TIDAL -> Sync Library Now?

Syncing my Tidal library did not remove the albums.

Hi @Michael_Cohen,

Just to confirm here, are you attempting to delete these albums one at a time or have you selected them as a group and tried to delete all of them in one go?

Is there any difference if you try to delete the albums individually if you have been trying to delete as a group?

If the behavior is still the same, I would like to gather some diagnostics for when this issue occurs. Please try deleting the albums individually and let me know the exact local time + date when you attempt to perform this action as well as which album you tried deleting.

Once I have this information, I can enable diagnostics mode for your account and take a look at logs if they reveal any additional info.

The albums I could not delete (subject of earlier email) now appear gone. I’ve enclosed a screen shot of another set of albums that will not delete.
These albums show up on my Tidal favorites for no reason. Though no one else has access to my account, I just changed my password and asked Tidal for assistance. In any case, after being unable to delete these titles from Roon, I deleted them on the Tidal site. They are no longer on my favorites list. I removed my Tidal service from Roon; all Tidal favorites were removed except for the circled albums, which remain. I’ve relinked Tidal to Roon and resynched Roon/Tidal, but these albums remain and cannot be deleted or hidden.

Hi @Michael_Cohen,

Can you please try deleting these albums again in Roon and let me know the exact local time + date you attempt to do so? I would like to enable diagnostics mode for your account in case logs contain further clues as to this behavior. Thanks!

I tried deleting the albums again between 9:39-9:40 pm Central Time on 12/26.
Thanks for your ongoing help.

Hi @Michael_Cohen,

Thanks for providing that timestamp. I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis. Once analysis has been completed, we might have some more information surrounding this behavior, I appreciate your patience until this request reaches the review queue!

Hi @Michael_Cohen,

I appreciate your patience until QA has had a chance to review the case. They have noted that there might be an issue with your Roon cache and it is suggested that we try clearing this out. Can I please ask you to use another PC on the same network and:

  • Stop RoonServer from running in the Web UI
  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting RoonServer from the WebUI and verify if the issue still occurs with the old TIDAL account

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.