Unable to edit newly created primary artist [fixed for B197+]

Using v1.3, I created a new primary artist ‘Led to Sea’.

I want to add an image, but when I select edit, the artist editor never appears and only the screenshot below is displayed.

I can easily cancel away from the screen and carry on using the app, but this looks like a bug to me.

I have successfuly used the editor on existing artists, it is just a new one that I cannot edit.


Thanks @Nick_Stamp. I’ve made a note. We’ll try to reproduce this during the week and see what’s up. I agree, it looks like a bug.

Hey Nick,

I just posted a thread about this too. After you tried to edit the artist can you still view the artist screen? After I tried to edit a newly created artist, now when I now try and view the artist all I get is an Artist loading… messages.

Best Regards,


No, I have not experienced this problem

This was a bug. A fix is coming next time we make a build.


Hey @support

I have create a new artist (since it didn’t exist) using the Choose Artist dialog and clicking on the “+ Create Artist”

The artist has been created, linked to a number of albums and is available in the Artist browser.

Initially the artist screen was viewable. I wanted to add a cover image so I clicked on Edit from the Artist screen and the Edit dialog was shown but it just shows the loading screen.

Now, when I try to view the artist all I get in the loading artist… screen!

Best Regards,


@support I can confirm this is fixed in build 200 and I have now been able to add an image to the newly created artist.
many thanks