Unable to restore from Dropbox backup

Hi all, I’m having some difficulty restoring from my dropbox backup I’m wondering if anyone can lend a hand.

I had a drive failure and had to reinstall OS. I’ve installed Roon, and followed the restore process and pointed it to Dropbox. It initialises, prepares, and then fails.

I thought it might be my internet connection so I installed the dropbox desktop app, but when I point Roon to the location on the hard drive where Dropbox keeps its files, it just says ‘Restore failed. Please check your backup folder and try again.

It gives me a list of the available backups but none seem to work.

Using Mac mini 2012, 16gb Ram, 2tb SSD, macOS 10.14, latest Roon.

Any thoughts? I can’t access the logs because no library files have been created yet (there is no Roon folder).

What was the time delay between installing roon and trying the restore? I ask as I’ve had a problem when I’ve tried to restore too soon and roon told me there was nothing to restore.

I had the same experience when I switched cores to an iMac Pro some time ago. The Roon people didn’t get back to me with possible solutions. I gave up and went back to my previous server.

I bought a new server recently and tried to restore several times before success. It took 6 hours.

The backup is from 28 December. I installed Roon in the morning and tried to restore immediately then tried again last night. How long delay should there be?

Oh lord. Any tips/tricks? :slight_smile:

Rebooting my router seemed to help a bit. At least enough so that it didn’t fail after many hours and finally complete after six hours. It kept stalling continually however so I had to keep an eye on it the whole time to un-stall and continue. This was all with Dropbox. I couldn’t figure out how to back up to a computer which may have worked better.

Hello @bluhska,

Can you please try downloading the backup from Dropbox first to your hard drive and then performing the restore? Please let me know if that helps.


Hi @noris thanks for your reply and support. I have rebooted the router and copied the Roon Backups folder to my internal storage. It still says ‘Restore failed. Please check your backup folder and try again’

Hi @bluhska – can you PM me a Dropbox link for your backup archive? We can take a look and try to confirm what’s going on here.


Hello @bluhska,

I wanted to confirm that we have received your dropbox link and it is still pending review by the QA team. As soon as it reached their queue I will be sure to let you know, but please do not remove those files from your Dropbox for the time being. Thanks!

– Noris

Understood. Thanks for your help. I’ll be eagerly waiting on your response :grin:

Hello @bluhska,

The QA team took a look over your case but we have been unable to successfully download the dropbox backup, we are presented with a “file is too large” error from Dropbox and can’t seem to download it for analysis. Can I kindly ask you to re-upload that backup to our servers instead of Dropbox? I will PM you upload instructions shortly.