Unable to see all songs on a given album

Core Machine (Operating system/System info/Roon build number)

Mac Mini 2018/ 3.2 GHz 6 Core Intel Core i7 / 64GB 2667MHz DDR4
Running Big Sur 11.2.3
Roon Version 1.8 (Build 783)

Network Details (Including networking gear model/manufacturer and if on)

Running Cat 5 cable from Eero router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Using KEF Egg computer speakers USB from Mac Mini

Description Of Issue

I have had this problem over the years, but Typically I could toggle switches and figure this out, but not today.

I am searching for Atomic Blonde Soundtrack to play while putting some furniture together. Only 2 songs come up, which MAY be because I had selected them previously as favorites? But I cannot find any switch or setting to toggle to see the remaining soundtrack songs, nor can I pay the entire sound track - almost as if it does not see it? When I go to th library, it shows a full album there in AIFF. When I search Roon, it finds only 2 songs, as FLAC?

I looked at the metadata and Atomic Blonde Soundtrack is how it is spelled, so when I search that, it should find it?

I attached screen images of the entire album in the Roon storage library, and what I see when I search Roon.

I am guessing it is something simple and stupid, but for the life of me I cannot figure this out.

Thanks to anyone for any help.

I am confused about your screen shots. One screen shot indicates you have the soundtrack as local music files, yet in the roon screen shot you are showing tracks that have been individually added to Roon from Tidal.

When you favorite a Tidal track you are Adding it to your library, this can have unintended consequences if you already have it as local music files. Any way, leaving the detangling to later, in the roon pic there is this:

click that and you will be taken to the whole album, not just the tracks you added individually to your library. At that point you can play the whole album, Add the whole album to your library (which I suggest you do).

Hi Daniel – Thanks so much for taking the time to answer and help explain.

I am only being transparent here, so excuse any ignorance if I have some simple setting turned on wrong or I need to toggle some setting to get this to work the way I’d like it to.

I would think, that the default would always be for Roon to display a full album, and then if there were 2 or 3 different versions of some tracks, users could have an algorithm for choosing which version as default. In any case, I did not search Tidal. I did a generic search in Roon for an album. So, in short, what I do not understand, is why the full album would not show up since I own it, and ripped it myself 1 month ago after already adding those 2 songs a while back as I did not own the CD then and had listened streamed through Tidal.

Why would it not Default to my own local version of the Full album, as opposed to choosing two songs I could have favorited in Tidal??

But, in my opinion, whether I chose to Favorite them previously in Tidal or not, if I own the entire album in identical quality, why would only two tracks show up as the default album view option?

Regarding your point about just listening to the album in Tidal and adding the whole album is Tidal does not have all songs available – so it looks like there are many licensing issues and many of the songs are not available (see image)

I was ultimately able to select “album versions” but for some reason it was not immediately present as an option (or I confess, perhaps I missed it but I was looking for it). In any case, once there, I could the choose to play my local version, but that is a bit too hard to get to play an entire album and the software could, I believe, make this easier - It just seems rather inefficient compared to how crazy easy it is to do just about everything else in Roon??

Is there a way to set the default to always be as my local library version?

Regardless - I would think, if I search for an album Atomic Blonde Soundtrack, and then it comes up, then when I select that album, all the songs should display. If there is a local and a Tidal version, then the user could choose which, but to only show the tracks that I added as favorites in Tidal and completely hide the entire album housed locally is a bit odd from an enduser standpoint.

Perhaps there is some setting I am mnissing?

But if I search Roon, why does it default to the two songs added through Tidal? I am not searching Tidal, I am searching all Roon.

Hope this makes sense - I appreciate your help

1 Like

Separately, and perhaps you can explain this - If you see my original screenshot, there was no option for “Versions” which ultimately allowed me to find my local AIFF ripped version. So, did I do something wrong?

If I would have seen the “Versions” option I would have chosen it.

I still think the user should be able to default to full album, or local version and not be stuck with 2 songs they might have months earlier added from Tidal, but even so I am just confused why I have the option at a later time, to search for different versions of the album, but I did not the initial time??

The initial screenshot without “Versions” was 09:20 AM. I came back and tried it again later and that screenshot is from 4:21 PM CST.

Hi @Brett_Laven

It looks like 2 tracks were favorited in TIDAL, which means they were synced to your Roon library. This appears to be the Primary Version of this album in your library, which is why you’re seeing this. There are no settings at this time to adjust which Primary Version is chosen automatically, but you can manually choose the primary version on the Versions tab.

As for the Versions tab not appearing — That should be happening, and it looks like it is now. Have you seen Versions not appear frequently? Are you able to reproduce this at all or is it always showing up now?

Hi dylan
Thanks for your help

  1. I think it. might be wise to consider offering a way for users to select the primary album in settings --just my 2 cents :slight_smile:

  2. Yes, I do have this problem frequently. I had a lot of stuff on Tidal and have ripped MULTIPLE versions of various albums with Hi res, vinyl rips, and import CD rips of the same album at times. So, I do know about “version”. Yes, I have had this frequently happen. On this occasion I figured it was just me not being used to the new format if something changed in the user interface. So I was looking for it and could not find it. Then, just a few hour later, there it is.

I tried it again with the same album just now and again “versions” was not visible as you can see in the screenshot with Date and time stamp ion the top right- sooooooo, yes, it is reproducible

1 Like

just hoping for help