Unable to see core on network. Unable to locate core via Roon App

Roon Core Machine

Info :: i5 CPU

The Intel NUC Mini PC re-imagines the desktop PC, a small computer with the power of a desktop, packing features for home entertainment, light gaming or office functionality. We offer this Fanless PC with a choice of three different CPUs: an aggressively-priced Core i3 machine, more powerful i5 and finally the i7. Essentially, the only difference between them is performance. If you need moderate performance then choose the dual-core Core i3 (2.4 GHz). If you need even more performance then choose the dual-core Core i5 (2.6 GHz with Turbo Boost to 3.5 GHz) or for the best performance possible from such a small PC then opt for the quad-core Core i7 (1.9 GHz with Turbo Boost to 4.2 GHz) along with the Plato chassis.

  • Windows 10 Home or Professional 64Bit
  • Completely silent – 0 Maintenance
  • A powerful Intel® Core™ Quad Core 8th Gen machine inside a tiny FANLESS NUC chassis
  • Up to 32GB DDR4 RAM
  • Flexible dual-storage design using M.2 SSD and a 2.5 inch HDD or SSD in combination
  • Rear Panel: 2x HDMI Out – 2x USB 2.0 – 1x Ethernet Port 1x DC in 1x Kensington Lock slot
  • Front Panel: 2x USB 3.0 – 1x USB C 1x DC in 1x Headphone and Microphone Jack
  • HDMI Out (Max Resolution – 4096×2160 @24Hz)
  • 12V – Low Power Consumption
  • VESA Mount Bracket included
  • TPM Module Installed

The new 8th Generation Intel Core processor – elevates your computing experience with an astounding 40 percent leap in productivity over a 7th Generation Intel Core. Brilliant 4k UHD entertainment, and easier, more convenient ways to interact with your PC.

Intel’s first quad-core U series processors enable portable, powerhouse thin and light PCs, so you can accomplish more on the go.

Networking Gear & Setup Details

Unifi Cloud Key 2
Unifi 16 way switch with POE
Unifi Security gateway PRO

Connected Audio Devices

Bryston BDP 1 Player. Configured for ROON playback mode
Bryston BDA2 DAC
Above connected via AES between BDP1/BDA2 DAC
Core is here : Fanless NUC Mini PC Intel 7th or 8th Gen i3 - i5 - i7 - Inside Tech

Number of Tracks in Library

None at present.
Just resubscibed to Tidal and ROON yesterday.

Description of Issue

Just resubscibed to ROON after moving home yesterday… as well as TIDAL.
Still using same router/setup (above) as old house but now unable to see ROON core on network now or connect via App as core undiscoverable…
Have tried different cables and connecting LAN directly to router etc but cannot still see core.
Link and description of core as above.
All was working fine before moving to new property.
Any settings I am not correcting on network etc ?
Any help would be greatly appreciated .
Thank You !
Kind regards,


Just messing around with this and …
connected my Roon endpoint directly to modem (bypassing / disconnecting UNIFI stuff) and I was able to find the core and download App immediately.
The Bryston is not connected so still no music…

Now, How can I connect all components to my UNIFI switch etc ? Also have other components like OPPO205 player etc…etc and all need to be connected via the 16 port switch…

Just tried again and Roon cannot find core any longer !
Cannot see on hub software…even when plugged directly into it.

Broadband service provider have said that it is not an issue on their side.

Should help greatly appreciated. Just need to ensure that the devices are seen … and usable!

were you running a fixed IP address before it was relocated?

connect a TV/HDMI monitor up to the NUC and see what IP address its showing or if its not maybe there is some other message like boot failure?

Some routers have a setting that only known devices can be connected. This is for security, but new devices will not find access.

You can temporarily change this so that the NUC can also find its way.

A look into the router also shows which devices are known and have been connected before. This helps to diagnose whether other devices were still without network access.

However, this requires a computer or a screen to at least look at the NUC.

Another problem is that the |NUC does not output a picture via the hdmi. Have tried a few different screens now. The company that provided this ‘Inside Tech’ have suggested reseating the CPU into another port…in the process of trying this now .

May also try Virgin Media again today to see if they can change any settings on the HUB remotely in order to help.

Trying the support team at Bryston to see if there is an issue with the BDP1 player…

Not heard anything from the guys at ROON so a bit disappointing to be honest

Bryston came back within a few hours and are looking at this now…

Basic troubleshooting is needed. Everything needs to be on the same ethernet lan segment (IP subnet) and there are a few ways to check this. Probably easiest, if your comfortable with the Unifi Controller in your Cloud Key is…
Clients → Wired

Then identify the Core and the BDP 1 Player devices.

Both should be on the same “IP subnet” which is a combination of IP address and subnet mask. For example a mask of means the first 3 octets are masked and create a ip subnet of example 10.1.2.x where x is the only difference between the two.

Then, once you’ve identified the IP address of the 2 devices login via the web using http://10.1.2.x substituting the 10.1.2 for whatever subnet and the x for the individual devices. Find the menu which tells you the address config for both Core and BDP 1. Verify that the subnets (something like match. Once all this is verified than you’ll have confidence the 2 devices are on “the same IP subnet”.

Next, disable Windows firewall to make sure that isn’t causing you issues. You can look this up online.

Are you running Roon Server under windows or the full GUI? Can you access Roon directly from the Windows 10 NuC locally? Not having a display on the NuC will limit your ability to troubleshoot. That isn’t a Roon issue and probably needs to be corrected before more troubleshooting can occur. I’d power it down, hook up a monitor, mouse, and keyboard, and power on. Do you see anything? Could the NuC have died during the move?

Hello @Amrik_Pahl,

Thank you so much for getting in touch when things stopped working… we’re sorry you ran into this and we’d love to help.

Thank you for your efforts every step of the way so far. @ipeverywhere has a really good point: are all of your devices on the same subnet? Firewall and antivirus disabling should do wonders too.

We’re hoping to hear back from you :pray:

Thanks to both you and your colleague for contacted me via my email to get this resolved. Much appreciated.
The Bryston issue with the BDP1 player is sorted out and I am now able to access TIDAL and my own music database and the player is working as it should. It was just a minor change to the setup…

Still unable to use ROON. Just tried the app again via my laptop.

Can you now help with this aspect ?

Kind regards,


Hello @Amrik_Pahl,

Thanks for keeping it touch over the weekend and for your patience while we returned to work.

Could you please tell us more about the behavior or any errors you see when you say you’re still unable to use Roon?

Hi Rebeka,

Can you please help ?
Bryston have managed to get their syatem and software working and I have just had a new Router installed by my service provider (Virgin Media) . The engineer also advsied that the service was working optimally.

The only thing missing now is the ROON.

Kind regards,


This topic was automatically closed after 10 days. New replies are no longer allowed.

Hey @Amrik_Pahl,

I am mortified I have missed on your last post for this long and that, accidentally this thread was closed… :pensive:

I wanted to follow up and hopefully get an update so that we can continue to help if needed :nerd_face:

Hi Rebeka,
Thanks for the message.
Bryston sorted out the problems I was having with their end at the time but the ROON issue still exists. I have not been able to use it since I resubscibed to ROON. I am still paying the monthly subscription unfortunately.

The ‘ROON READY’ mode has been switched off from the software of the BDP1 so I have not been able to use it for the last few months. Can anything be done ? It was working previously prior to me cancelling the previous susbcription, with the same hardware - including modem etc.

Any assistance would be greatly appreciated.

Kind regards,


Hey @Amrik_Pahl,

When you say:

The ‘ROON READY’ mode has been switched off from the software of the BDP1 so I have not been able to use it for the last few months

Is this something you can enable in the BDP1 software?