Unable to setup Roon ARC, again

Roon Core Machine

Networking Gear & Setup Details

My ISP is KPN and the KPN modem is Experia Box version 10

Connected Audio Devices

Number of Tracks in Library

23447 tracks

Description of Issue

Following to the recent upgrade to the latest version, I’ve lost the connexion with ARC
Here is the message I got:
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“77.aaa.bbb.ccc”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<?xml version=\"1.0\" encoding=\"utf-8\"?>\n<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n800\ndo not execute action(all)\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>\n”}
Could you please help?
Thanks in advance for your reply.

Hi @Pascal_Longlade,

You probably need to set a port forwarding rule in your Experia Box for the Roon Arc port to the IP-address of the machine with the Roon Core.

More info in article:

1 Like

Hi @Pascal_Longlade,

In my opinion @Joost_Hoogland is right.

To create a manual port forwarding, in the Roon APP under Settings → Roon Arc write down the ip address and the port number.

Please take a look at the screenshots in below post for a how to create the port forwarding.

Let us know if this works.

Kind regards,


1 Like

Hi Joost,
Thanks for your reply. I was able to set a port forwarding manually and it now works.

1 Like

Hi Maarten,
Please see my response to Joost.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.